summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2020-03-11 11:14:59 -0400
committerChristopher Lemmer Webber <cwebber@dustycloud.org>2020-03-11 15:13:30 -0400
commitdfe15d9919ba74b28ec8adca8a88cc02ef8c43af (patch)
tree5570b42d1c718640b831016c9fbae55caba37d2c
parentf7f67495ba0c2f08b0372e925725b4d196e037b6 (diff)
downloadpatches-dfe15d9919ba74b28ec8adca8a88cc02ef8c43af.tar
patches-dfe15d9919ba74b28ec8adca8a88cc02ef8c43af.tar.gz
gnu: Add xa.
* gnu/packages/assembly.scm (xa): New variable.
-rw-r--r--gnu/packages/assembly.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 0fdddc88e9..0a24220e18 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
;;; Copyright © 2019 Andy Tai <atai@atai.org>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -342,3 +343,31 @@ Supported architectures are:
@item spc700
@end itemize")
(license license:gpl2)))
+
+(define-public xa
+ (package
+ (name "xa")
+ (version "2.3.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.floodgap.com/retrotech/xa"
+ "/dists/xa-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0y5sd247g11jfk5msxy91hz2nhpy7smj125dzfyfhjsjnqk5nyw6"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; TODO: custom test harness, not sure how it works
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)) ; no "configure" script
+ #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))))
+ (native-inputs `(("perl" ,perl)))
+ (home-page "https://www.floodgap.com/retrotech/xa/")
+ (synopsis "Two-pass portable cross-assembler")
+ (description
+ "xa is a high-speed, two-pass portable cross-assembler.
+It understands mnemonics and generates code for NMOS 6502s (such
+as 6502A, 6504, 6507, 6510, 7501, 8500, 8501, 8502 ...),
+ CMOS 6502s (65C02 and Rockwell R65C02) and the 65816.")
+ (license license:gpl2)))