summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-03-09 17:31:00 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-10 18:16:39 +0100
commit98619142b8c54287136216d0008871f9170a1808 (patch)
treec478f5e36aea845eadf97542b2e8469a45a0d7b4
parent0e20e2c3871075a8fa117e2139f9ac494e08f0de (diff)
downloadpatches-98619142b8c54287136216d0008871f9170a1808.tar
patches-98619142b8c54287136216d0008871f9170a1808.tar.gz
gnu: guile-next: Update to 3.0.1 with bug-fix for crash.
* gnu/packages/guile.scm (guile-3.0): Update to 3.0.1 with "guile-3.0-crash.patch". * gnu/packages/patches/guile-3.0-crash.patch: New file. * gnu/local.mk (dist_patch_DATA): Use it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/guile.scm8
-rw-r--r--gnu/packages/patches/guile-3.0-crash.patch17
3 files changed, 24 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a0e013aead..99baddea92 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -977,6 +977,7 @@ dist_patch_DATA = \
%D%/packages/patches/guile-1.8-cpp-4.5.patch \
%D%/packages/patches/guile-2.2-default-utf8.patch \
%D%/packages/patches/guile-2.2-skip-oom-test.patch \
+ %D%/packages/patches/guile-3.0-crash.patch \
%D%/packages/patches/guile-default-utf8.patch \
%D%/packages/patches/guile-gdbm-ffi-support-gdbm-1.14.patch \
%D%/packages/patches/guile-linux-syscalls.patch \
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 3116f3c30a..1d9d93d774 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -292,14 +292,18 @@ without requiring the source code to be rewritten.")
(package
(inherit guile-2.2)
(name "guile-next") ;to be renamed to "guile"
- (version "3.0.0")
+ (version "3.0.1")
(source (origin
(inherit (package-source guile-2.2))
(uri (string-append "mirror://gnu/guile/guile-"
version ".tar.xz"))
(sha256
(base32
- "0x8ca6q1qdmk29lh12gj6ngvgn7kp79w42rxfgwrpxm9jmjqs4y9"))))
+ "1jakps3127h8g69ixgb4zwc8v2g29dmwql1vi3pwg30kzp8fm5nn"))
+ (patches
+ (append (search-patches "guile-3.0-crash.patch")
+ (origin-patches (package-source guile-2.2))))))
+
(arguments
(substitute-keyword-arguments (package-arguments guile-2.2)
;; XXX: On ARMv7, work around <https://bugs.gnu.org/39208> by disabling
diff --git a/gnu/packages/patches/guile-3.0-crash.patch b/gnu/packages/patches/guile-3.0-crash.patch
new file mode 100644
index 0000000000..510834ab57
--- /dev/null
+++ b/gnu/packages/patches/guile-3.0-crash.patch
@@ -0,0 +1,17 @@
+Fix crash due to: <https://issues.guix.gnu.org/issue/39266>.
+
+diff --git a/libguile/struct.c b/libguile/struct.c
+index 3dbcc71d4..ddcbe46d2 100644
+--- a/libguile/struct.c
++++ b/libguile/struct.c
+@@ -139,7 +139,9 @@ set_vtable_access_fields (SCM vtable)
+ nfields = len / 2;
+
+ bitmask_size = (nfields + 31U) / 32U;
+- unboxed_fields = scm_gc_malloc_pointerless (bitmask_size, "unboxed fields");
++ unboxed_fields =
++ scm_gc_malloc_pointerless (bitmask_size * sizeof (*unboxed_fields),
++ "unboxed fields");
+ memset (unboxed_fields, 0, bitmask_size * sizeof(*unboxed_fields));
+
+ /* Update FLAGS according to LAYOUT. */