summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-11 15:19:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-11 15:19:54 +0200
commit578e4cf465ffc2d235c8de1e847b51ad8c65715c (patch)
tree9f84fb3c8679c1bb2f478ec89d56b1ef12dbd8cf
parent2bc5d5d57e47079873d2683edef9e7ce9249b83f (diff)
downloadpatches-578e4cf465ffc2d235c8de1e847b51ad8c65715c.tar
patches-578e4cf465ffc2d235c8de1e847b51ad8c65715c.tar.gz
gnu: python2-ipykernel: Downgrade to 4.10.1.
This is the last version actually supported by ipykernel. * gnu/packages/python-xyz.scm (python2-ipython): Downgrade to 4.10.1. [arguments]: Remove custom 'check phase. [propagated-inputs]: Add python2-tornado, python2-traitlets. [native-inputs]: Add python2-mock, python2-pytest-cov. (python-ipykernel)[properties): Declare python2-ipykernel as the python2- variant.
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 12 insertions, 14 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b50946d5fa..823e524192 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5479,36 +5479,34 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(synopsis "IPython Kernel for Jupyter")
(description
"This package provides the IPython kernel for Jupyter.")
+ (properties `((python2-variant . ,(delay python2-ipykernel))))
(license license:bsd-3)))
-;; Version 5.1.1 and above no longer support Python 2.
+;; Version 5.x and above no longer support Python 2.
(define-public python2-ipykernel
(package
(name "python2-ipykernel")
- (version "5.1.0")
+ (version "4.10.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ipykernel" version))
(sha256
- (base32 "0br95qhrd5k65g10djngiy27hs0642301hlf2q142i8djabvzh0g"))))
+ (base32 "1yzmdiy1djsszqp54jzd8ym8h4hpl67zjq83j2kxbkp0rwmlpdzf"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (setenv "HOME" "/tmp")
- (invoke "pytest" "-v")
- #t)))))
+ `(#:python ,python-2))
(propagated-inputs
`(("python2-ipython" ,python2-ipython)
;; imported at runtime during connect
- ("python2-jupyter-client" ,python2-jupyter-client)))
+ ("python2-jupyter-client" ,python2-jupyter-client)
+ ("python2-tornado" ,python2-tornado)
+ ("python2-traitlets" ,python2-traitlets)))
(native-inputs
- `(("python2-pytest" ,python2-pytest)
- ("python2-nose" ,python2-nose)))
+ `(("python2-mock" ,python2-mock)
+ ("python2-nose" ,python2-nose)
+ ("python2-pytest" ,python2-pytest)
+ ("python2-pytest-cov" ,python2-pytest-cov)))
(home-page "https://ipython.org")
(synopsis "IPython Kernel for Jupyter")
(description