summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamien Cassou <damien@cassou.me>2020-03-04 16:31:51 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-11 18:42:09 +0100
commit51f187bee54d84c4a5000feaf25452bc339b660b (patch)
treea4efb7e468764caea96b13169b54e744a67a2f75
parentd8a822f4620857bb31b24d71ff80840442ec694b (diff)
downloadpatches-51f187bee54d84c4a5000feaf25452bc339b660b.tar
patches-51f187bee54d84c4a5000feaf25452bc339b660b.tar.gz
gnu: Add clipnotify.
* gnu/packages/xdisorg.scm (clipnotify): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/xdisorg.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index f46ba6714c..5d1a259bad 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2020 David Wilson <david@daviwil.com>
;;; Copyright © 2020 Ivan Vilata i Balaguer <ivan@selidor.net>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2020 Damien Cassou <damien@cassou.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2116,3 +2117,50 @@ font and theme settings when a complete desktop environment (GNOME, KDE) is
not running. With a simple @file{.xsettingsd} configuration file one can avoid
configuring visual settings in different UI toolkits separately.")
(license license:bsd-3)))
+
+(define-public clipnotify
+ (package
+ (name "clipnotify")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cdown/clipnotify.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1v3ydm5ljy8z1savmdxrjyx7a5bm5013rzw80frp3qbbjaci0wbg"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (doc (string-append %output "/share/doc/" ,name "-" ,version)))
+ (install-file "clipnotify" bin)
+ (install-file "README.md" doc)
+ #t))))
+ #:make-flags (list "CC=gcc")
+ #:tests? #f))
+ (inputs
+ `(("libx11" ,libx11)
+ ("libXfixes" ,libxfixes)))
+ (home-page "https://github.com/cdown/clipnotify")
+ (synopsis "Notify on new X clipboard events")
+ (description "@command{clipnotify} is a simple program that, using the
+XFIXES extension to X11, waits until a new selection is available and then
+exits.
+
+It was primarily designed for clipmenu, to avoid polling for new selections.
+
+@command{clipnotify} doesn't try to print anything about the contents of the
+selection, it just exits when it changes. This is intentional -- X11's
+selection API is verging on the insane, and there are plenty of others who
+have already lost their sanity to bring us xclip/xsel/etc. Use one of those
+tools to complement clipnotify.")
+ (license license:public-domain)))