summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-10 15:13:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-10 15:15:02 +0100
commit49a221151cca3a29b0bf50e9087137204326b3da (patch)
treec1ad34cc947b8939d1e50bb7cdb12905c841d81d
parent06c8638830c991a24a731e95fd1c599da095d034 (diff)
downloadpatches-49a221151cca3a29b0bf50e9087137204326b3da.tar
patches-49a221151cca3a29b0bf50e9087137204326b3da.tar.gz
gnu: Add r-ppcor.
* gnu/packages/cran.scm (r-ppcor): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 56e86e3b74..f6be0d387b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20727,3 +20727,26 @@ Encyclopedia of Integer Sequences} (OEIS) in the function help page.")
lines (isolines) and contour polygons (isobands) from regularly spaced grids
containing elevation data.")
(license license:expat)))
+
+(define-public r-ppcor
+ (package
+ (name "r-ppcor")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ppcor" version))
+ (sha256
+ (base32
+ "1x9b2kb8s0bp92b17gby0jwzzr3i4cf3ap9c4nq7m8fav72g0y3a"))))
+ (properties `((upstream-name . "ppcor")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)))
+ (home-page "https://cran.r-project.org/web/packages/ppcor/")
+ (synopsis "Partial and semi-partial correlation")
+ (description
+ "This package provides users not only with a function to readily
+calculate the higher-order partial and semi-partial correlations but also with
+statistics and p-values of the correlation coefficients.")
+ (license license:gpl2)))