summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-03-09 22:41:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-03-09 23:55:42 +0100
commitef617dedd28ffa5c32cf9e0ee2482ce32aa195f4 (patch)
treee41ce431ba7a775cb8e415bc476678d3acecf3ae
parent77dbc1c5377875e57577267e872b8c644bed0a43 (diff)
downloadpatches-ef617dedd28ffa5c32cf9e0ee2482ce32aa195f4.tar
patches-ef617dedd28ffa5c32cf9e0ee2482ce32aa195f4.tar.gz
gnu: csvkit: Update to 1.0.5.
* gnu/packages/wireservice.scm (csvkit): Update to 1.0.5. [source]: Remove upstreamed patch. * gnu/packages/patches/csvkit-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/csvkit-fix-tests.patch45
-rw-r--r--gnu/packages/wireservice.scm8
3 files changed, 4 insertions, 50 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 16d7cd9529..a0e013aead 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -798,7 +798,6 @@ dist_patch_DATA = \
%D%/packages/patches/cpufrequtils-fix-aclocal.patch \
%D%/packages/patches/crawl-upgrade-saves.patch \
%D%/packages/patches/crda-optional-gcrypt.patch \
- %D%/packages/patches/csvkit-fix-tests.patch \
%D%/packages/patches/clucene-contribs-lib.patch \
%D%/packages/patches/cube-nocheck.patch \
%D%/packages/patches/cursynth-wave-rand.patch \
diff --git a/gnu/packages/patches/csvkit-fix-tests.patch b/gnu/packages/patches/csvkit-fix-tests.patch
deleted file mode 100644
index cb9ec39cb0..0000000000
--- a/gnu/packages/patches/csvkit-fix-tests.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/tests/test_utilities/test_csvsql.py b/tests/test_utilities/test_csvsql.py
-index e6ec4af..4f47980 100644
---- a/tests/test_utilities/test_csvsql.py
-+++ b/tests/test_utilities/test_csvsql.py
-@@ -197,7 +197,7 @@ class TestCSVSQL(CSVKitTestCase, EmptyFileTests):
- utility.run()
- output = output_file.getvalue()
- output_file.close()
-- self.assertEqual(output, 'a,b,c\n1,2,3\n0,5,6\n')
-+ self.assertEqual(output, 'a,b,c\n1,2.0,3.0\n0,5.0,6.0\n')
-
- def test_no_prefix_unique_constraint(self):
- self.get_output(['--db', 'sqlite:///' + self.db_file, '--insert', 'examples/dummy.csv', '--unique-constraint', 'a'])
-diff --git a/tests/test_utilities/test_sql2csv.py b/tests/test_utilities/test_sql2csv.py
-index a0c3d3e..babcfd6 100644
---- a/tests/test_utilities/test_sql2csv.py
-+++ b/tests/test_utilities/test_sql2csv.py
-@@ -121,23 +121,23 @@ class TestSQL2CSV(CSVKitTestCase, EmptyFileTests):
- input_file.close()
-
- def test_unicode(self):
-- expected = self.csvsql('examples/test_utf8.csv')
-+ self.csvsql('examples/test_utf8.csv')
- csv = self.get_output(['--db', 'sqlite:///' + self.db_file, '--query', 'select * from foo'])
-- self.assertEqual(csv.strip(), expected)
-+ self.assertEqual(csv.strip(), 'foo,bar,baz\n1.0,2.0,3\n4.0,5.0,ʤ')
-
- def test_no_header_row(self):
- self.csvsql('examples/dummy.csv')
- csv = self.get_output(['--db', 'sqlite:///' + self.db_file, '--no-header-row', '--query', 'select * from foo'])
-
- self.assertTrue('a,b,c' not in csv)
-- self.assertTrue('1,2,3' in csv)
-+ self.assertTrue('1,2.0,3.0' in csv)
-
- def test_linenumbers(self):
- self.csvsql('examples/dummy.csv')
- csv = self.get_output(['--db', 'sqlite:///' + self.db_file, '--linenumbers', '--query', 'select * from foo'])
-
- self.assertTrue('line_number,a,b,c' in csv)
-- self.assertTrue('1,1,2,3' in csv)
-+ self.assertTrue('1,1,2.0,3.0' in csv)
-
- def test_wildcard_on_sqlite(self):
- self.csvsql('examples/iris.csv')
diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index eab76970f4..0d772b54d1 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -198,17 +199,16 @@ for xls and xlsx files support to all @code{agate.Table} instances.")))
(define-public csvkit
(package
(name "csvkit")
- (version "1.0.4")
+ (version "1.0.5")
(source (origin
(method url-fetch)
(uri (pypi-uri "csvkit" version))
(sha256
(base32
- "1830lb95rh1iyi3drlwxzb6y3pqkii0qiyzd40c1kvhvaf1s6lqk"))
- (patches (search-patches "csvkit-fix-tests.patch"))))
+ "1ffmbzk4rxnl1yhqfl58v7kvl5m9cbvjm8v7xp4mvr00sgs91lvv"))))
(build-system python-build-system)
(native-inputs
- `(("python-psycopg2" ,python-psycopg2) ;; Used to test PostgreSQL support.
+ `(("python-psycopg2" ,python-psycopg2) ; to test PostgreSQL support
("python-sphinx" ,python-sphinx)
("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
(inputs