summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-03-09 04:23:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-03-09 16:01:18 +0100
commitc3bde0b7af30a7d228e74bee44ddc4c4b1f4532c (patch)
treef39ef1f76675f472b75273df8b5c547dd16634e8
parent1fad0b8674cf97a7e102e98ab31fcebe07ae9515 (diff)
downloadpatches-c3bde0b7af30a7d228e74bee44ddc4c4b1f4532c.tar
patches-c3bde0b7af30a7d228e74bee44ddc4c4b1f4532c.tar.gz
gnu: libseccomp: Update to 2.4.3.
* gnu/packages/linux.scm (libseccomp): Update to 2.4.3. [source]: Remove upstreamed patch. * gnu/packages/patches/libseccomp-open-aarch64.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/linux.scm5
-rw-r--r--gnu/packages/patches/libseccomp-open-aarch64.patch27
3 files changed, 2 insertions, 31 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2f0768f036..16d7cd9529 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1114,7 +1114,6 @@ dist_patch_DATA = \
%D%/packages/patches/libmpeg2-global-symbol-test.patch \
%D%/packages/patches/libmygpo-qt-fix-qt-5.11.patch \
%D%/packages/patches/libmygpo-qt-missing-qt5-modules.patch \
- %D%/packages/patches/libseccomp-open-aarch64.patch \
%D%/packages/patches/libsndfile-armhf-type-checks.patch \
%D%/packages/patches/libsndfile-CVE-2017-8361-8363-8365.patch \
%D%/packages/patches/libsndfile-CVE-2017-8362.patch \
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a8b74bda22..489cd55e6e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5030,7 +5030,7 @@ of flash storage.")
(define-public libseccomp
(package
(name "libseccomp")
- (version "2.4.2")
+ (version "2.4.3")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/seccomp/libseccomp/"
@@ -5038,8 +5038,7 @@ of flash storage.")
"/libseccomp-" version ".tar.gz"))
(sha256
(base32
- "0nsq81acrbkdr8zairxbwa33bj2a6126npp76b4srjl472sjfkxm"))
- (patches (search-patches "libseccomp-open-aarch64.patch"))))
+ "07crwxqzvl5k2b90a47ii9wgvi09s9hsy5b5jddw9ylp351d25fg"))))
(build-system gnu-build-system)
(native-inputs
`(("which" ,which)))
diff --git a/gnu/packages/patches/libseccomp-open-aarch64.patch b/gnu/packages/patches/libseccomp-open-aarch64.patch
deleted file mode 100644
index 6e62825892..0000000000
--- a/gnu/packages/patches/libseccomp-open-aarch64.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-This patch fixes the build failure on AArch64 reported
-at <https://github.com/seccomp/libseccomp/pull/191>.
-
-From cc21c1b48d35f9d34ef2da0e184af3855bfeee5f Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
-Date: Wed, 20 Nov 2019 14:11:12 -0500
-Subject: [PATCH] tests: use openat instead of open
-
-On arm64, __NR_open is not defined, openat is always used. Let's use openat
-instead, which is defined for architectures currently.
----
- tests/15-basic-resolver.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/15-basic-resolver.c b/tests/15-basic-resolver.c
-index 6badef1..4884faf 100644
---- a/tests/15-basic-resolver.c
-+++ b/tests/15-basic-resolver.c
-@@ -55,7 +55,7 @@ int main(int argc, char *argv[])
- unsigned int arch;
- char *name = NULL;
-
-- if (seccomp_syscall_resolve_name("open") != __NR_open)
-+ if (seccomp_syscall_resolve_name("openat") != __NR_openat)
- goto fail;
- if (seccomp_syscall_resolve_name("read") != __NR_read)
- goto fail;