summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-03-10 00:54:02 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-03-10 10:54:48 +0200
commitba726ebc2d1e7df42edc061d168488791b15a497 (patch)
tree0f8e4d4729fe0390177fbc1d4bff006c52028231
parent43d4eb8fc4a6074a872c80bd0b2263b98472f01a (diff)
downloadpatches-ba726ebc2d1e7df42edc061d168488791b15a497.tar
patches-ba726ebc2d1e7df42edc061d168488791b15a497.tar.gz
gnu: mumble: Disable statistic gathering by default.
Fixes <https://bugs.gnu.org/25201> * gnu/packages/telephone.scm (mumble)[arguments]: Add phase to disable statistic gathering by default. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/telephony.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index a645c58562..fe6c230693 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;; Copyright © 2019 Ivan Vilata i Balaguer <ivan@selidor.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -462,6 +463,12 @@ address of one of the participants.")
(substitute* "src/mumble/TextToSpeech_unix.cpp"
(("libspeechd.h") "speech-dispatcher/libspeechd.h"))
#t))
+ ;; disable statistic gathering by default. see <https://bugs.gnu.org/25201>
+ (add-before 'configure 'fix-statistic-gathering-default
+ (lambda _
+ (substitute* "src/mumble/Settings.cpp"
+ (("bUsage = true;") "bUsage = false;"))
+ #t))
(add-before 'install 'disable-murmur-ice
(lambda _
(substitute* "scripts/murmur.ini.system"