summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-02-25 18:07:52 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-09 14:45:38 +0200
commitfb29d7d70cc1f477ce323b5cb3d820547fe23a59 (patch)
tree6c095bff041e3b79e2b5d55a7122d1e62ee817dd
parent61daf2dbc9502fd7f7bb4cbf9866b96d1631afa2 (diff)
downloadpatches-fb29d7d70cc1f477ce323b5cb3d820547fe23a59.tar
patches-fb29d7d70cc1f477ce323b5cb3d820547fe23a59.tar.gz
gnu: Add vim-asyncrun.
* gnu/packages/vim.scm (vim-asyncrun): New variable.
-rw-r--r--gnu/packages/vim.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index b468347380..5b03124e38 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -847,3 +847,28 @@ through its msgpack-rpc API.")
(synopsis "Guix integration in Vim")
(description "This package provides support for GNU Guix in Vim.")
(license license:vim)))
+
+(define-public vim-asyncrun
+ (package
+ (name "vim-asyncrun")
+ (version "2.6.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/skywind3000/asyncrun.vim")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1n0yzv8psskhx8h4g7dz64h2llm9mnljhvl4hrnsjx6znkni8vwp"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("plugin" "share/vim/vimfiles/")
+ ("doc/" "share/vim/vimfiles/doc" #:include ("asyncrun.txt")))))
+ (home-page "https://github.com/skywind3000/asyncrun.vim")
+ (synopsis "Run Async Shell Commands in Vim")
+ (description "This plugin takes the advantage of new APIs in Vim 8 (and
+NeoVim) to enable you to run shell commands in background and read output in the
+quickfix window in realtime.")
+ (license license:expat)))