summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-03-04 10:48:45 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-07 22:30:06 +0100
commit83ac7cb42b7157a4317c1219521f6eb0046a9ed6 (patch)
tree1ad8f2aa9375ded317860b013f1f8b58dacd4f51
parentd9476a3700e23b2fad145cb3f90d84a7fcf3ed59 (diff)
downloadpatches-83ac7cb42b7157a4317c1219521f6eb0046a9ed6.tar
patches-83ac7cb42b7157a4317c1219521f6eb0046a9ed6.tar.gz
gnu: brotli: Remove package
Same package is provided by google-brotli. * gnu/packages/compression.scm (brotli): Redefine as a deprecated alias for "google-brotli". Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/compression.scm47
1 files changed, 4 insertions, 43 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 241ad5e221..33f9380236 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -885,49 +885,6 @@ possible and can compress in parallel. This is especially useful for large
tarballs.")
(license license:bsd-2)))
-(define-public brotli
- (let ((commit "e992cce7a174d6e2b3486616499d26bb0bad6448")
- (revision "1"))
- (package
- (name "brotli")
- (version (string-append "0.1-" revision "."
- (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/bagder/libbrotli.git")
- (commit commit)
- (recursive? #t)))
- (file-name (string-append name "-" version ".tar.xz"))
- (sha256
- (base32
- "1qxxsasvwbbbh6dl3138y9h3fg0q2v7xdk5jjc690bdg7g1wrj6n"))
- (modules '((guix build utils)))
- (snippet '(begin
- ;; This is a recursive submodule that is
- ;; unnecessary for this package, so delete it.
- (delete-file-recursively "brotli/terryfy")
- #t))))
- (build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
- (arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'autogen
- (lambda _
- (mkdir "m4")
- (invoke "autoreconf" "-vfi"))))))
- (home-page "https://github.com/bagder/libbrotli/")
- (synopsis "Implementation of the Brotli compression algorithm")
- (description
- "Brotli is a general-purpose lossless compression algorithm. It is
-similar in speed to deflate but offers denser compression. This package
-provides encoder and a decoder libraries: libbrotlienc and libbrotlidec,
-respectively, based on the reference implementation from Google.")
- (license license:expat))))
-
(define-public bsdiff
(package
(name "bsdiff")
@@ -1885,6 +1842,10 @@ with @code{deflate} but offers more dense compression.
The specification of the Brotli Compressed Data Format is defined in RFC 7932.")
(license license:expat)))
+(define-public brotli
+ ;; We used to provide an older version under the name "brotli".
+ (deprecated-package "brotli" google-brotli))
+
(define-public ucl
(package
(name "ucl")