summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Becze <mjbecze@riseup.net>2020-03-08 11:19:16 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-03-08 11:19:16 +0100
commit1eb3b2b666fd6ae5c0e3b09aa08c97b9d23e26be (patch)
treef449760470831c75abfae8df7fb58f136ecba9b8
parente2ca10a46fc322940430e1a5b88dd4616f5c5e77 (diff)
downloadpatches-1eb3b2b666fd6ae5c0e3b09aa08c97b9d23e26be.tar
patches-1eb3b2b666fd6ae5c0e3b09aa08c97b9d23e26be.tar.gz
gnu: Add emacs-org-journal.
* gnu/packages/emacs-xyz.scm (emacs-org-journal): New Variable.
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8b75169d4d..e09ec9b278 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -61,6 +61,7 @@
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
;;; Copyright © 2020 Masaya Tojo <masaya@tojo.tokyo>
+;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21734,6 +21735,32 @@ Separated Value) files. It follows the format as defined in RFC 4180 \"Common
Format and MIME Type for CSV Files\" (@url{http://tools.ietf.org/html/rfc4180}).")
(license license:gpl3+)))
+(define-public emacs-org-journal
+ (package
+ (name "emacs-org-journal")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bastibe/org-journal.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18dqd0jy2x530lk0h4fcn9cld9qh4w7b3vxa60fpiia628vsv1dg"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/bastibe/org-journal")
+ (synopsis "Simple Org mode journaling mode")
+ (description
+ "Org Journal is a set of functions to maintain a simple personal diary /
+journal using in Emacs, adapted from
+@url{https://www.emacswiki.org/emacs/PersonalDiary}. Convenient bindings
+allow the creation of journal records in the current daily, weekly, monthly or
+yearly file and search within all records or specified time intervals. All
+records can be browsed and searched from the Emacs Calendar for convenience.
+All entries in a specified TODO state will be carried over to the next day.")
+ (license license:bsd-3)))
+
(define-public emacs-ddskk
;; XXX: Upstream adds code names to their release tags, so version and code
;; name below need to be updated together.