summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-03-08 13:52:20 -0500
committerGuix Patches Tester <>2020-03-08 18:56:11 +0000
commitf5ee75660e8f17517481655856081e5d3d56588b (patch)
tree59b2b44f22d9a80d8eaf5da8d91fc375008ef9e8
parentc32897b6e409c94fca4102f68d80db95e60c5f37 (diff)
downloadpatches-series-3110.tar
patches-series-3110.tar.gz
gnu: emacs-browse-at-remote: Update to 0.14.0.series-3110
* gnu/packages/emacs-xyz.scm (emacs-browse-at-remote): Update to 0.14.0.
-rw-r--r--gnu/packages/emacs-xyz.scm31
1 files changed, 25 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e09ec9b278..18210788d8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10785,7 +10785,7 @@ Idris.")
(define-public emacs-browse-at-remote
(package
(name "emacs-browse-at-remote")
- (version "0.10.0")
+ (version "0.14.0")
(source
(origin
(method git-fetch)
@@ -10794,7 +10794,7 @@ Idris.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0vhia7xmszcb3lxrb8wh93a3knjfzj48h8nhj4fh8zj1pjz6args"))))
+ (base32 "0bx4ns0jb0sqrjk1nsspvl3mhz3n12925azf7brlwb1vcgnji09v"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-f" ,emacs-f)
@@ -10805,11 +10805,30 @@ Idris.")
`(#:tests? #t
#:test-command '("ert-runner")))
(home-page "https://github.com/rmuslimov/browse-at-remote")
- (synopsis "Open github/gitlab/bitbucket/stash page from Emacs")
+ (synopsis "Open a local file's corresponding Git forge page from Emacs")
(description
- "This Emacs package allows you to open a target page on
-github/gitlab (or bitbucket) by calling @code{browse-at-remote} command.
-It supports dired buffers and opens them in tree mode at destination.")
+ "This Emacs package allows you to open the web page of a Git forge that
+corresponds to a local checkout of a given file.
+
+The currently supported forges are
+@itemize
+@item Atlassian Bitbucket,
+@item Atlassian Stash,
+@item Fedora Pagure,
+@item GitHub (including gists),
+@item GitLab,
+@item Phabricator,
+@item git.savannah.gnu.org, and
+@item sourcehut.
+@end itemize
+
+The supported types of Emacs buffers include
+@itemize
+@item file buffers,
+@item dired buffers,
+@item magit-mode buffers representing code, and
+@item vc-annotate-mode buffers.
+@end itemize\n")
(license license:gpl3+)))
(define-public emacs-tiny