summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-03-07 12:02:22 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-03-07 12:48:18 +0100
commitc0dc4179091f85fe4b8a2bbdb07c154a7f0408ed (patch)
tree7f628bc764e5ad322859a6cc431ef422bdb06811
parentbeecf815dbd1256c4ffaccebffc2be2024111bbd (diff)
downloadpatches-c0dc4179091f85fe4b8a2bbdb07c154a7f0408ed.tar
patches-c0dc4179091f85fe4b8a2bbdb07c154a7f0408ed.tar.gz
gnu: spice: Update to 0.14.3.
* gnu/packages/spice.scm (spice): Update to 0.14.3. [source]: Remove obsolete patch. * gnu/packages/patches/spice-fix-test-armhf.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/image.scm2
-rw-r--r--gnu/packages/patches/spice-fix-test-armhf.patch19
-rw-r--r--gnu/packages/spice.scm7
-rw-r--r--gnu/packages/video.scm4
5 files changed, 6 insertions, 27 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4e3f4261d1..7dd65ac001 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1407,7 +1407,6 @@ dist_patch_DATA = \
%D%/packages/patches/snappy-add-O2-flag-in-CmakeLists.txt.patch \
%D%/packages/patches/sooperlooper-build-with-wx-30.patch \
%D%/packages/patches/soundconverter-remove-gconf-dependency.patch \
- %D%/packages/patches/spice-fix-test-armhf.patch \
%D%/packages/patches/steghide-fixes.patch \
%D%/packages/patches/suitesparse-mongoose-cmake.patch \
%D%/packages/patches/superlu-dist-awpm-grid.patch \
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index c26e0dc338..101fe0dc2a 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1300,7 +1300,7 @@ ISO/IEC 15444-1).")
(commit (string-append "release-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1dqyrq3p8bkgvj4ci50ac342hjnhyz6xxvhiwp7wpi3v3nbj7s02"))))
+ (base32 "12bs2rfmmy021087i10vxibdbbvd5vld0vk3h5hymhpz7rgszcmg"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
diff --git a/gnu/packages/patches/spice-fix-test-armhf.patch b/gnu/packages/patches/spice-fix-test-armhf.patch
deleted file mode 100644
index 5c51bd6ede..0000000000
--- a/gnu/packages/patches/spice-fix-test-armhf.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Fix test failure on armhf and ppc64el:
-https://gitlab.freedesktop.org/spice/spice-server/issues/31
-
-Taken from upstream:
-https://gitlab.freedesktop.org/spice/spice/commit/19f9f454e0777d851f26d14df0c7984267c57015
-
-diff --git a/server/tests/test-qxl-parsing.c b/server/tests/test-qxl-parsing.c
-index 60ca8f88c62441e02577ced21e4f60a08ad4171a..234bdabc9ce619d0799b5136f1d72357b0b2f490 100644
---- a/server/tests/test-qxl-parsing.c
-+++ b/server/tests/test-qxl-parsing.c
-@@ -96,7 +96,7 @@ static void test_memslot_invalid_slot_id(void)
- RedMemSlotInfo mem_info;
- init_meminfo(&mem_info);
-
-- memslot_get_virt(&mem_info, 1 << mem_info.memslot_id_shift, 16, 0);
-+ memslot_get_virt(&mem_info, UINT64_C(1) << mem_info.memslot_id_shift, 16, 0);
- }
-
- static void test_memslot_invalid_addresses(void)
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index a57e0151ca..404b2a7a05 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 David Craven <david@craven.ch>
-;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;;
@@ -191,16 +191,15 @@ which allows users to view a desktop computing environment.")
(define-public spice
(package
(name "spice")
- (version "0.14.2")
+ (version "0.14.3")
(source (origin
(method url-fetch)
(uri (string-append
"https://www.spice-space.org/download/releases/"
"spice-server/spice-" version ".tar.bz2"))
- (patches (search-patches "spice-fix-test-armhf.patch"))
(sha256
(base32
- "19r999py9v9c7md2bb8ysj809ag1hh6djl1ik8jcgx065s4b60xj"))))
+ "05512vkfayw18ypg4acqbbpr72nsnsz9bj7k8c2wyrvnl3j4n7am"))))
(build-system gnu-build-system)
(propagated-inputs
`(("openssl" ,openssl)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6719e1e047..e7929727d1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1548,7 +1548,7 @@ To load this plugin, specify the following option when starting mpv:
(define-public youtube-dl
(package
(name "youtube-dl")
- (version "2020.02.16")
+ (version "2020.03.06")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/ytdl-org/youtube-dl/"
@@ -1556,7 +1556,7 @@ To load this plugin, specify the following option when starting mpv:
version ".tar.gz"))
(sha256
(base32
- "1ip0p7gifwmkls8ppfvz89j1lh82dg60zmvabj8njnhj170ikkdb"))))
+ "16c10rgkjrjv115w4r7gsr9hcakqq5s2cg250b1hwvxdsxqp8vnv"))))
(build-system python-build-system)
(arguments
;; The problem here is that the directory for the man page and completion