summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-09 11:53:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:43 +0200
commita361f4128cc4c52269090be6261e56dc85c257c0 (patch)
treedac0594718f6fda9255a6c8cbdc0fa395b8a5273
parent619ca0230c5ec06eb73051dac2459a2d0ffdd2fa (diff)
downloadpatches-a361f4128cc4c52269090be6261e56dc85c257c0.tar
patches-a361f4128cc4c52269090be6261e56dc85c257c0.tar.gz
gnu: Add texlive-hyphen-armenian.
* gnu/packages/tex.scm (texlive-hyphen-armenian): New variable.
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 14d82c7cc7..bfb48322b3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1385,6 +1385,42 @@ language.")
Greek.")
(license license:lppl1.3+)))
+(define-public texlive-hyphen-armenian
+ (let ((template (texlive-hyphen-package
+ "texlive-hyphen-armenian" "hy"
+ (list "/source/generic/hyph-utf8/languages/hy/generate_patterns_hy.rb")
+ (base32
+ "0z666y580w1kpxssdanz67ykq257lf11a1mnp1jrn08zijvfrw9c"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-before 'build 'build-patterns
+ (lambda _
+ (let ((target (string-append (getcwd)
+ "/tex/generic/hyph-utf8/patterns/tex")))
+ (mkdir-p target)
+ (with-directory-excursion "source/generic/hyph-utf8/languages/hy/"
+ (substitute* "generate_patterns_hy.rb"
+ (("\\$file = File.new.*")
+ (string-append "$file = File.new(\"" target
+ "/hyph-hy.tex\",\"w\")\n")))
+ (invoke "ruby" "generate_patterns_hy.rb"))
+ #t)))
+ (add-after 'install 'install-hyph-hy.tex
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (target (string-append out "/share/texmf-dist/tex")))
+ (copy-recursively "tex" target)
+ #t)))))))
+ (synopsis "Hyphenation patterns for Armenian")
+ (description "The package provides hyphenation patterns for the Armenian
+language.")
+ ;; Any version of the LGPL.
+ (license license:lgpl3+))))
+
(define-public texlive-hyph-utf8
(package
(inherit (simple-texlive-package