summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-05 21:46:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-05 21:46:05 +0100
commit7032c1cc6040a14e482e71b0cfbdedf957da4f8a (patch)
tree12882d2ad6d99b95abd85fed23245e0ac4853f2e
parent8e04b233f130e01b5b6a41dfcdeb5e622d43f751 (diff)
downloadpatches-7032c1cc6040a14e482e71b0cfbdedf957da4f8a.tar
patches-7032c1cc6040a14e482e71b0cfbdedf957da4f8a.tar.gz
gnu: Add python-zarr.
* gnu/packages/python-xyz.scm (python-zarr): New variable.
-rw-r--r--gnu/packages/python-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c9865d08e2..0505ad5f40 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15776,6 +15776,46 @@ codecs for use in data storage and communication applications.")
(description "This package draws tree structures using characters.")
(license license:expat)))
+(define-public python-zarr
+ (package
+ (name "python-zarr")
+ (version "2.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "zarr" version))
+ (sha256
+ (base32
+ "026n3sjzjv2gmwx6y72b8ij0hk42bc8zdbvfj5gdqzd4i6wj3ajk"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-service-tests
+ (lambda _
+ (setenv "ZARR_TEST_ABS" "0")
+ (setenv "ZARR_TEST_MONGO" "0")
+ (setenv "ZARR_TEST_REDIS" "0")
+ #t))
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv" "-k" "not lmdb")
+ #t)))))
+ (propagated-inputs
+ `(("python-asciitree" ,python-asciitree)
+ ("python-fasteners" ,python-fasteners)
+ ("python-numcodecs" ,python-numcodecs)
+ ("python-numpy" ,python-numpy)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/zarr-developers/zarr-python")
+ (synopsis "Chunked, compressed, N-dimensional arrays for Python")
+ (description
+ "This package provides an implementation of chunked, compressed,
+N-dimensional arrays for Python.")
+ (license license:expat)))
+
(define-public python-anndata
(package
(name "python-anndata")