summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-03-02 10:18:52 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-03-06 15:04:34 -0500
commit1d3c6a31b5a5240418c9bdc17da26c4fb6fa1daa (patch)
treeae80973087754a51b05c0dc286aceaadc90d473b
parentc2f41cb3e8d80d56d0b6eb4a81a23764c844dbce (diff)
downloadpatches-1d3c6a31b5a5240418c9bdc17da26c4fb6fa1daa.tar
patches-1d3c6a31b5a5240418c9bdc17da26c4fb6fa1daa.tar.gz
gnu: wxmaxima: Update to 20.02.4.
* gnu/packages/maths.scm (wxmaxima): Update to 20.02.4. [arguments]: Enable tests and set #:test-target to "test". [native-inputs]: Add xorg-server-for-tests.
-rw-r--r--gnu/packages/maths.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a990ffc45e..eeea8b65be 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2016, 2018 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2016, 2018, 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
@@ -3030,7 +3030,7 @@ point numbers.")
(define-public wxmaxima
(package
(name "wxmaxima")
- (version "20.01.3")
+ (version "20.02.4")
(source
(origin
(method git-fetch)
@@ -3039,10 +3039,13 @@ point numbers.")
(commit (string-append "Version-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "18fj2m1qwlbavivpixph112wq9hxy3hh7c8q07djc3bhrzf2a7v7"))))
+ (base32 "106a7jrjwfmymzj70nsv44fm3jbxngr8pmkaghhpwy0ln38lhf54"))))
(build-system cmake-build-system)
(native-inputs
- `(("gettext" ,gettext-minimal)))
+ `(("gettext" ,gettext-minimal)
+ ("xorg-server" ,xorg-server-for-tests)))
+ ;; TODO: Add libomp for multithreading support.
+ ;; As of right now, enabling libomp causes the imageCells.wxm test to fail.
(inputs
`(("wxwidgets" ,wxwidgets)
("maxima" ,maxima)
@@ -3051,9 +3054,16 @@ point numbers.")
("gtk+" ,gtk+)
("shared-mime-info" ,shared-mime-info)))
(arguments
- `(#:tests? #f ; no check target
+ `(#:test-target "test"
#:phases
(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ (setenv "HOME" (getcwd))
+ #t))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (string-append (assoc-ref outputs "out")