summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-03-07 11:30:11 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-03-07 11:30:11 +0100
commit0bc557fd70895219f08fe0fc6d5b28190a837605 (patch)
treea3043a2b23032059173aed7bd0f3d639edc534ec
parentaf5c4efff6c4b1b3f3546db1202266ed25ade76d (diff)
downloadpatches-0bc557fd70895219f08fe0fc6d5b28190a837605.tar
patches-0bc557fd70895219f08fe0fc6d5b28190a837605.tar.gz
gnu: cl-dbus: Remove unneeded inputs.
* gnu/packages/lisp-xyz.scm (cl-dbus)[propagated-inputs]: Remove iolib subpackages now that iolib properly references them.
-rw-r--r--gnu/packages/lisp-xyz.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index c4874112e1..cdc1419e41 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6367,16 +6367,13 @@ power of CXML is available when necessary.")
(sha256
(base32
"0fw2q866yddbf23nk9pxphm9gsasx35vjyss82xzvndnjmzlqfl5"))))
- ;; Inputs must be propagated or else packages depending on this won't have the necessary packages.
+ ;; Inputs must be propagated or else packages depending on this won't
+ ;; have the necessary packages.
(propagated-inputs
`(("alexandria" ,sbcl-alexandria)
("trivial-garbage" ,sbcl-trivial-garbage)
("babel" ,sbcl-babel)
("iolib" ,sbcl-iolib)
- ("iolib+multiplex" ,(@@ (gnu packages lisp-xyz) sbcl-iolib+multiplex))
- ("iolib+syscalls" ,(@@ (gnu packages lisp-xyz) sbcl-iolib+syscalls))
- ("iolib+streams" ,(@@ (gnu packages lisp-xyz) sbcl-iolib+streams))
- ("iolib+sockets" ,(@@ (gnu packages lisp-xyz) sbcl-iolib+sockets))
("ieee-floats" ,sbcl-ieee-floats)
("flexi-streams" ,sbcl-flexi-streams)
("cl-xmlspam" ,sbcl-cl-xmlspam)