summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-06 08:55:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-06 09:16:48 +0100
commitcc2c2850ce1ccf863b7e69f8ac6734f1b659c212 (patch)
tree6ee2162c74a8c46efb1a0e5df4133ffa3611fff6
parent5f603fab23e7df7e7b76566b3add24b65e92f807 (diff)
downloadpatches-cc2c2850ce1ccf863b7e69f8ac6734f1b659c212.tar
patches-cc2c2850ce1ccf863b7e69f8ac6734f1b659c212.tar.gz
gnu: Add python-pytest-black.
* gnu/packages/python-xyz.scm (python-pytest-black): New variable.
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bc7e10e785..c003bef585 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7311,6 +7311,31 @@ designed to efficiently cope with extremely large amounts of data.")
(define-public python2-tables
(package-with-python2 python-tables))
+(define-public python-pytest-black
+ (package
+ (name "python-pytest-black")
+ (version "0.3.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-black" version))
+ (sha256
+ (base32
+ "04lppqydxm0f3f3x0l8hj7v0j6d8syj34jc37yzqwqcyqsnaga81"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-black" ,python-black)
+ ("python-toml" ,python-toml)))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/shopkeep/pytest-black")
+ (synopsis "Pytest plugin to enable format checking with black")
+ (description
+ "This package provides a pytest plugin to enable format checking with the
+Python code formatter \"black\".")
+ (license license:expat)))
+
(define-public python-pyasn1
(package
(name "python-pyasn1")