summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-06 08:52:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-06 09:16:48 +0100
commitc777ecb3721133ce9f79880e6536c9fc11830249 (patch)
tree23a2329fae8d8508af09253a86a3cd6f55c4a815
parent538c1a024a288cb674f4e6048bb9086963949358 (diff)
downloadpatches-c777ecb3721133ce9f79880e6536c9fc11830249.tar
patches-c777ecb3721133ce9f79880e6536c9fc11830249.tar.gz
gnu: Add python-pathspec.
* gnu/packages/python-xyz.scm (python-pathspec): New variable.
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dd0d56548c..3eac8622e7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3155,6 +3155,25 @@ used in text editing environments to provide a complete and integrated
feature-set for programming Python effectively.")
(license license:expat)))
+(define-public python-pathspec
+ (package
+ (name "python-pathspec")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pathspec" version))
+ (sha256
+ (base32
+ "15lvs4awlg8xzl0l4gk9y53xx4yqmqvsv44pglv39m70y85afajn"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/cpburnz/python-path-specification")
+ (synopsis "Utility library for gitignore style pattern matching of file paths")
+ (description
+ "This package provides a utility library for gitignore style pattern
+matching of file paths.")
+ (license license:mpl2.0)))
+
(define-public python-black
(package
(name "python-black")