summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-06 11:18:01 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-06 12:31:07 +0100
commit8c6aae463628a205451a9eb60327e6579ed9fe53 (patch)
tree982783dfe4ba078355d4df94197a99434503edf4
parent6448c2e156fed5b2e9375f0ae378fbbce38ffb36 (diff)
downloadpatches-8c6aae463628a205451a9eb60327e6579ed9fe53.tar
patches-8c6aae463628a205451a9eb60327e6579ed9fe53.tar.gz
gnu: libgit2-glib: Adjust inputs.
* gnu/packages/gnome.scm (libgit2-glib)[native-inputs]: Move LIBSSH2 ... [inputs]: ... here. Move LIBGIT2 ... [propagated-inputs]: ... here. New field.
-rw-r--r--gnu/packages/gnome.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 05c877ed35..fa5fce5ad2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9629,13 +9629,15 @@ for usage on small and big screens.")
(native-inputs
`(("glib:bin" ,glib "bin") ;; For glib-mkenums
("gobject-introspection" ,gobject-introspection)
- ("libssh2" ,libssh2)
("pkg-config" ,pkg-config)
("python-pygobject" ,python-pygobject)
("python-wrapper" ,python-wrapper)
("vala" ,vala)))
(inputs
`(("glib" ,glib)
+ ("libssh2" ,libssh2)))
+ (propagated-inputs
+ `(;; In Requires of libgit2-glib.pc.
("libgit2" ,libgit2)))
(synopsis "GLib wrapper around the libgit2 Git access library")
(description "libgit2-glib is a GLib wrapper library around the libgit2 Git