summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-06 11:24:41 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-06 12:31:08 +0100
commit7154f5ef4beb5fa0f04049784c4bb815aff36a7c (patch)
tree30da1bb4e4513ae9c2eca37781808ec148a3840a
parent535895025927451921a14d0f20dce40dce2d70ae (diff)
downloadpatches-7154f5ef4beb5fa0f04049784c4bb815aff36a7c.tar
patches-7154f5ef4beb5fa0f04049784c4bb815aff36a7c.tar.gz
gnu: python-pygit2: Update to 1.1.0.
* gnu/packages/python-xyz.scm (python-pygit2): Update to 1.1.0. [propagated-inputs]: Remove PYTHON-SIX and PYTHON-TOX. Add PYTHON-CACHED-PROPERTY. (python2-pygit2): Remove variable (Python 2 is no longer supported).
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b4f20dcd3b..d2cd270ab7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3783,21 +3783,20 @@ color scales, and color space conversion easy. It has support for:
(define-public python-pygit2
(package
(name "python-pygit2")
- (version "0.28.2")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pygit2" version))
(sha256
- (base32 "11kzj5mjkspvplnpdb6bj8dcj6rgmkk986k8hjcklyg5yaxkz32d"))))
+ (base32 "1hs0pqqzn1yjxqk86nq7p0lvsklwnlyi5xwyzr7d5nrs19dmsjbg"))))
(build-system python-build-system)
(arguments
'(#:tests? #f)) ; tests don't run correctly in our environment
(propagated-inputs
- `(("python-six" ,python-six)
+ `(("python-cached-property" ,python-cached-property)
("python-cffi" ,python-cffi)
- ("libgit2" ,libgit2)
- ("python-tox" ,python-tox)))
+ ("libgit2" ,libgit2)))
(native-inputs
`(("python-pytest" ,python-pytest)))
(home-page "https://github.com/libgit2/pygit2")
@@ -3807,9 +3806,6 @@ library, libgit2 implements Git plumbing.")
;; GPL2.0 only, with linking exception.
(license license:gpl2)))
-(define-public python2-pygit2
- (package-with-python2 python-pygit2))
-
(define-public python-pyparsing
(package
(name "python-pyparsing")