summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-03-06 12:19:15 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-03-06 12:46:26 +0100
commit59d4c8c2bfb34c87092dcc7e883e67fc0c9aab58 (patch)
treebe62ae635e79c998984e81f463a0eb61ab306718
parent852fa6050e475c8d98e7526a41967f1265a0ad43 (diff)
downloadpatches-59d4c8c2bfb34c87092dcc7e883e67fc0c9aab58.tar
patches-59d4c8c2bfb34c87092dcc7e883e67fc0c9aab58.tar.gz
gnu: Add gnome-boxes.
* gnu/packages/gnome.scm (gnome-boxes): New variable.
-rw-r--r--gnu/packages/gnome.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fddca4d0f1..abfcb2cf3c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9873,3 +9873,58 @@ index files needed for Adwaita to be used outside of GNOME.")
integrate seamlessly with the GNOME desktop.")
(home-page "https://wiki.gnome.org/Apps/Polari")
(license license:gpl2+)))
+
+(define-public gnome-boxes
+ (package
+ (name "gnome-boxes")
+ (version "3.35.91")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gnome-boxes/"
+ (version-major+minor version) "/"
+ "gnome-boxes-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0l96spz6pc8q4l5p9a58cc0kgvdr7pbc89hy6ixn72k5pl3s7fxj"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:glib-or-gtk? #t
+ #:configure-flags (list "-Drdp=false"
+ (string-append "-Dc_link_args=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib/gnome-boxes"))))
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-compile-resources
+ ("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
+ ("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("itstool" ,itstool)
+ ("intltool" ,intltool)
+ ("vala" ,vala)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libarchive" ,libarchive)
+ ("gtk" ,gtk+)
+ ("gtk-vnc" ,gtk-vnc)
+ ("libosinfo" ,libosinfo)
+ ("libsecret" ,libsecret)
+ ("libsoup" ,libsoup)
+ ("libusb" ,libusb)
+ ("libvirt" ,libvirt)
+ ("libvirt-glib" ,libvirt-glib)
+ ("libxml" ,libxml2)
+ ("spice-gtk" ,spice-gtk)
+ ("sparql-query" ,sparql-query)
+ ("vte" ,vte)
+ ("webkitgtk" ,webkitgtk)
+ ("tracker" ,tracker)
+ ("libgudev" ,libgudev)))
+ (home-page "https://wiki.gnome.org/Apps/Boxes")
+ (synopsis "View, access, and manage remote and virtual systems")
+ (description "GNOME Boxes is a simple application to view, access, and
+manage remote and virtual systems.")
+ (license (list
+ ;; For data/icons/empty-boxes.png.
+ license:cc-by2.0
+ ;; For all others.
+ license:lgpl2.0+))))