summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-03-06 15:01:08 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-03-06 15:02:33 +0100
commit5424e680b829c72ed7531333a532643e6f62ceb3 (patch)
treee887134898cceecb1453812051f87d758056774f
parent462ca0bbb73206569073814dd8daa7e2b6a2a048 (diff)
downloadpatches-5424e680b829c72ed7531333a532643e6f62ceb3.tar
patches-5424e680b829c72ed7531333a532643e6f62ceb3.tar.gz
gnu: carla: Partially fix start-up.
This fixes <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=39942> but carla still fails to start. Reported by Nathan Dehnel <ncdehnel@gmail.com>. * gnu/packages/audio.scm (carla)[arguments]: Add ‘make-carla-executable’ phase.
-rw-r--r--gnu/packages/audio.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 2406aa16b2..d0810bda0a 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3930,11 +3930,17 @@ as is the case with audio plugins.")
(list (string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
+ (delete 'configure) ; no configure script
(add-before 'build 'set-CC-variable-and-show-features
(lambda _
(setenv "CC" "gcc")
(invoke "make" "features")))
- (delete 'configure))))
+ (add-after 'install 'make-carla-executable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (chmod (string-append out "/share/carla/carla") #o555)
+ #t)))
+ )))
(inputs
`(("alsa-lib" ,alsa-lib)
("ffmpeg" ,ffmpeg)