summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-06 08:55:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-06 09:16:48 +0100
commit2ceff35f077e942e97c9af63b067269c03f1e842 (patch)
treeb9f41a54bfa14921069b7a02bc1bbcfbc482624e
parentcc2c2850ce1ccf863b7e69f8ac6734f1b659c212 (diff)
downloadpatches-2ceff35f077e942e97c9af63b067269c03f1e842.tar
patches-2ceff35f077e942e97c9af63b067269c03f1e842.tar.gz
gnu: Add python-get-version.
* gnu/packages/python-xyz.scm (python-get-version): New variable.
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c003bef585..58df879b75 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7336,6 +7336,35 @@ designed to efficiently cope with extremely large amounts of data.")
Python code formatter \"black\".")
(license license:expat)))
+(define-public python-get-version
+ (package
+ (name "python-get-version")
+ (version "2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "get_version" version))
+ (sha256
+ (base32
+ "1g15jyx33vkxavv9hwv275cs4g9bp2i1y942raw3fxamq8kbaml1"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pygments" ,python-pygments)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-black" ,python-pytest-black)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-setuptools" ,python-setuptools)
+ ("python-testpath" ,python-testpath)))
+ (home-page "https://github.com/flying-sheep/get_version")
+ (synopsis "Version helper in the spirit of versioneer")
+ (description
+ "This package provides a version helper that lets you automatically use
+the latest @code{vX.X.X} Git tag as the version in your Python package. It
+also supports getting the version from Python source distributions or, once
+your package is installed, via @code{pkg_resources} (part of
+@code{setuptools}).")
+ (license license:gpl3+)))
+
(define-public python-pyasn1
(package
(name "python-pyasn1")