summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-05 21:45:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-05 21:45:46 +0100
commit241409cd8afe45fdecfbd7d24cdeb08aa2a43884 (patch)
tree6b989f263555189d8b838b55ad6ce9707df83432
parent24ce64216e1f03c14c1693cb9d1051691b758b1f (diff)
downloadpatches-241409cd8afe45fdecfbd7d24cdeb08aa2a43884.tar
patches-241409cd8afe45fdecfbd7d24cdeb08aa2a43884.tar.gz
gnu: Add python-numcodecs.
* gnu/packages/python-xyz.scm (python-numcodecs): New variable.
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7003f60b15..0642d32631 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15734,6 +15734,31 @@ infrastructure at import time, runtime, or statically (using the included pycc
tool).")
(license license:bsd-3)))
+(define-public python-numcodecs
+ (package
+ (name "python-numcodecs")
+ (version "0.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "numcodecs" version))
+ (sha256
+ (base32
+ "0kbfr8pl3x9glsypbq8hzim003f16ml1b1cvgrh4w1sdvgal6j7g"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)
+ ("python-msgpack" ,python-msgpack)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/zarr-developers/numcodecs")
+ (synopsis "Buffer compression and transformation codecs")
+ (description
+ "This Python package provides buffer compression and transformation
+codecs for use in data storage and communication applications.")
+ (license license:expat)))
+
(define-public python-anndata
(package
(name "python-anndata")