summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-18 22:00:24 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-03-04 21:30:57 +0100
commite85af137244924a383f203914467ca6f4b4ebf15 (patch)
tree62e633043e8ce24c2547fcd53c9558e52c4bb3ca
parentdbc8a6e7500c50a3014e4de52f31ec16c2d4f1b3 (diff)
downloadpatches-e85af137244924a383f203914467ca6f4b4ebf15.tar
patches-e85af137244924a383f203914467ca6f4b4ebf15.tar.gz
gnu: Update pypi.python.org home pages & use HTTPS.
* gnu/packages/check.scm (python-unittest2, python-pytest-localserver) (python-discover)[home-page]: Follow (HTTPS) redirections. * gnu/packages/fontutils.scm (python2-defcon)[home-page]: Likewise. * gnu/packages/glib.scm (python2-pygobject-2)[home-page]: Likewise. * gnu/packages/graph.scm (python-igraph)[home-page]: Likewise. * gnu/packages/graphviz.scm (xdot)[home-page]: Likewise. * gnu/packages/pdf.scm (python-poppler-qt5)[home-page]: Likewise. * gnu/packages/python-web.scm (python-zope-event, python-zope-testing) (python-zope-testrunner, python-zope-i18nmessageid, python-zope-schema) (python-zope-configuration, python-zope-proxy, python-zope-location) (python-zope-security))[home-page]: Likewise. * gnu/packages/python-xyz.scm (python-setuptools,python-six) (python2-dogtail, python2-enum, python-enum34, python-unidecode) (python-numpydoc, python-decorator, python-drmaa, python-pathlib2) (python-ly, python-msgpack, python-termcolor, python-colorama) (python-pluggy, python2-pathlib2, python-rfc3987)[home-page]: Likewise.
-rw-r--r--gnu/packages/check.scm6
-rw-r--r--gnu/packages/fontutils.scm2
-rw-r--r--gnu/packages/glib.scm2
-rw-r--r--gnu/packages/graph.scm2
-rw-r--r--gnu/packages/graphviz.scm2
-rw-r--r--gnu/packages/pdf.scm2
-rw-r--r--gnu/packages/python-web.scm18
-rw-r--r--gnu/packages/python-xyz.scm34
8 files changed, 34 insertions, 34 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index fa6575173f..d5a9a9b92a 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -756,7 +756,7 @@ interfaces and processes.")
(propagated-inputs
`(("python-six" ,python-six)
("python-traceback2" ,python-traceback2)))
- (home-page "http://pypi.python.org/pypi/unittest2")
+ (home-page "https://pypi.org/project/unittest2/")
(synopsis "Python unit testing library")
(description
"Unittest2 is a replacement for the unittest module in the Python
@@ -1540,7 +1540,7 @@ the last py.test invocation.")
(synopsis "Py.test plugin to test server connections locally")
(description "Pytest-localserver is a plugin for the pytest testing
framework which enables you to test server connections locally.")
- (home-page "https://pypi.python.org/pypi/pytest-localserver")
+ (home-page "https://pypi.org/project/pytest-localserver/")
(license license:expat)))
(define-public python-pytest-xprocess
@@ -1994,7 +1994,7 @@ especially -cover-package.")
(base32
"0y8d0zwiqar51kxj8lzmkvwc3b8kazb04gk5zcb4nzg5k68zmhq5"))))
(build-system python-build-system)
- (home-page "http://pypi.python.org/pypi/discover/")
+ (home-page "https://pypi.org/project/discover/")
(synopsis
"Python test discovery for unittest")
(description
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 8d39730a7b..a8c9e3ddc0 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -678,7 +678,7 @@ files. UFO is a file format that stores fonts source files.")
(propagated-inputs
`(("python2-fonttools" ,python2-fonttools)
("python2-ufolib" ,python2-ufolib)))
- (home-page "https://pypi.python.org/pypi/defcon")
+ (home-page "https://pypi.org/project/defcon/")
(synopsis "Flexible objects for representing @acronym{UFO, unified font object} data")
(description
"Defcon is a set of @acronym{UFO, unified font object} based objects
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 72d5ea0bdd..03d6be596b 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -670,7 +670,7 @@ useful for C++.")
(arguments
`(#:tests? #f ;segfaults during tests
#:configure-flags '("LIBS=-lcairo-gobject")))
- (home-page "https://pypi.python.org/pypi/PyGObject")
+ (home-page "https://pypi.org/project/PyGObject/")
(synopsis "Python bindings for GObject")
(description
"Python bindings for GLib, GObject, and GIO.")
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 63eb36fd7d..ab2bf1daf0 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -119,7 +119,7 @@ more.")
(native-inputs
`(("pkg-config" ,pkg-config)
("python-pytest" ,python-pytest)))
- (home-page "http://pypi.python.org/pypi/python-igraph")
+ (home-page "https://pypi.org/project/python-igraph/")
(synopsis "Python bindings for the igraph network analysis library")))
(define-public r-igraph
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 365fe1a113..c4f88caa88 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -308,7 +308,7 @@ structure and layout algorithms.")
("gtk+" ,gtk+)
("python-pycairo" ,python-pycairo)
("python-pygobject" ,python-pygobject)))
- (home-page "https://pypi.python.org/pypi/xdot")
+ (home-page "https://pypi.org/project/xdot/")
(synopsis "Interactive viewer for graphviz dot files")
(description "Xdot is an interactive viewer for graphs written in
@code{graphviz}’s dot language. Internally, it uses the xdot output format as
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 1ad37706d0..b40940ecab 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -226,7 +226,7 @@ When present, Poppler is able to correctly render CJK and Cyrillic text.")
("python-pyqt" ,python-pyqt)
("poppler-qt5" ,poppler-qt5)
("qtbase" ,qtbase)))
- (home-page "https://pypi.python.org/pypi/python-poppler-qt5")
+ (home-page "https://pypi.org/project/python-poppler-qt5/")
(synopsis "Python bindings for Poppler-Qt5")
(description
"This package provides Python bindings for the Qt5 interface of the
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 44f2976ec2..08d75525be 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -972,7 +972,7 @@ object to help create WSGI responses.")
(base32
"1ksbc726av9xacml6jhcfyn828hlhb9xlddpx6fcvnlvmpmpvhk9"))))
(build-system python-build-system)
- (home-page "https://pypi.python.org/pypi/zope.event")
+ (home-page "https://pypi.org/project/zope.event/")
(synopsis "Event publishing system for Python")
(description "Zope.event provides an event publishing API, intended for
use by applications which are unaware of any subscribers to their events. It
@@ -1051,7 +1051,7 @@ that have uses outside of the Zope framework.")
(for-each delete-file (find-files "." "(\\.pyc|~)$"))
#t))))
(build-system python-build-system)
- (home-page "https://pypi.python.org/pypi/zope.testing")
+ (home-page "https://pypi.org/project/zope.testing/")
(synopsis "Zope testing helpers")
(description "Zope.testing provides a number of testing utilities for HTML
forms, HTTP servers, regular expressions, and more.")
@@ -1082,7 +1082,7 @@ forms, HTTP servers, regular expressions, and more.")
("unzip" ,unzip)))
(propagated-inputs
`(("python-zope-interface" ,python-zope-interface)))
- (home-page "https://pypi.python.org/pypi/zope.testrunner")
+ (home-page "https://pypi.org/project/zope.testrunner/")
(synopsis "Zope testrunner script")
(description "Zope.testrunner provides a script for running Python
tests.")
@@ -1109,7 +1109,7 @@ tests.")
(base32
"1rslyph0klk58dmjjy4j0jxy21k03azksixc3x2xhqbkv97cmzml"))))
(build-system python-build-system)
- (home-page "https://pypi.python.org/pypi/zope.i18nmessageid")
+ (home-page "https://pypi.org/project/zope.i18nmessageid/")
(synopsis "Message identifiers for internationalization")
(description "Zope.i18nmessageid provides facilities for declaring
internationalized messages within program source text.")
@@ -1140,7 +1140,7 @@ internationalized messages within program source text.")
`(("python-zope-testing" ,python-zope-testing)
("python-coverage" ,python-coverage)
("python-nose" ,python-nose)))
- (home-page "https://pypi.python.org/pypi/zope.schema")
+ (home-page "https://pypi.org/project/zope.schema/")
(synopsis "Zope data schemas")
(description "Zope.scheme provides extensions to zope.interface for
defining data schemas.")
@@ -1165,7 +1165,7 @@ defining data schemas.")
(propagated-inputs
`(("python-zope-i18nmessageid" ,python-zope-i18nmessageid)
("python-zope-schema" ,python-zope-schema)))
- (home-page "https://pypi.python.org/pypi/zope.configuration")
+ (home-page "https://pypi.org/project/zope.configuration/")
(synopsis "Zope Configuration Markup Language")
(description "Zope.configuration implements ZCML, the Zope Configuration
Markup Language.")
@@ -1190,7 +1190,7 @@ Markup Language.")
'(#:tests? #f)) ; FIXME: Tests can't find zope.interface.
(propagated-inputs
`(("python-zope-interface" ,python-zope-interface)))
- (home-page "https://pypi.python.org/pypi/zope.proxy")
+ (home-page "https://pypi.org/project/zope.proxy/")
(synopsis "Generic, transparent proxies")
(description "Zope.proxy provides generic, transparent proxies for Python.
Proxies are special objects which serve as mostly-transparent wrappers around
@@ -1219,7 +1219,7 @@ brokering, etc.) for which the proxy is responsible.")
(propagated-inputs
`(("python-zope-proxy" ,python-zope-proxy)
("python-zope-schema" ,python-zope-schema)))
- (home-page "https://pypi.python.org/pypi/zope.location/")
+ (home-page "https://pypi.org/project/zope.location/")
(synopsis "Zope location library")
(description "Zope.location implements the concept of \"locations\" in
Zope3, which are are special objects that have a structural location.")
@@ -1253,7 +1253,7 @@ Zope3, which are are special objects that have a structural location.")
("python-zope-location" ,python-zope-location)
("python-zope-testrunner" ,python-zope-testrunner)
("python-zope-testing" ,python-zope-testing)))
- (home-page "https://pypi.python.org/pypi/zope.security")
+ (home-page "https://pypi.org/project/zope.security/")
(synopsis "Zope security framework")
(description "Zope.security provides a generic mechanism to implement
security policies on Python objects.")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4473a0df2c..3cd1686d28 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -748,7 +748,7 @@ other machines, such as over the network.")
;; One could bootstrap with an internal untested setuptools.
(arguments
`(#:tests? #f))
- (home-page "https://pypi.python.org/pypi/setuptools")
+ (home-page "https://pypi.org/project/setuptools/")
(synopsis
"Library designed to facilitate packaging Python projects")
(description
@@ -1111,7 +1111,7 @@ from the Python interpreter, or as a small part of a larger application.")
(native-inputs
`(("python-py" ,python-py)
("python-pytest" ,python-pytest-bootstrap)))
- (home-page "https://pypi.python.org/pypi/six/")
+ (home-page "https://pypi.org/project/six/")
(synopsis "Python 2 and 3 compatibility utilities")
(description
"Six is a Python 2 and 3 compatibility library. It provides utility
@@ -1282,7 +1282,7 @@ Python 3.3+.")
(arguments `(#:python ,python-2
#:tests? #f)) ; invalid command "test"
;; Currently no offical homepage.
- (home-page "https://pypi.python.org/pypi/dogtail/")
+ (home-page "https://pypi.org/project/dogtail/")
(synopsis "GUI test tool and automation framework written in Python")
(description
"Dogtail is a GUI test tool and automation framework written in Python.
@@ -1393,7 +1393,7 @@ bug tracker.")
(build-system python-build-system)
(arguments
`(#:python ,python-2))
- (home-page "https://pypi.python.org/pypi/enum/")
+ (home-page "https://pypi.org/project/enum/")
(synopsis "Robust enumerated type support in Python")
(description
"This provides a module for robust enumerations in Python. It has
@@ -1414,7 +1414,7 @@ compatibility.")
(base32
"1cgm5ng2gcfrkrm3hc22brl6chdmv67b9zvva9sfs7gn7dwc9n4a"))))
(build-system python-build-system)
- (home-page "https://pypi.python.org/pypi/enum34")
+ (home-page "https://pypi.org/project/enum34/")
(synopsis "Backported Python 3.4 Enum")
(description
"Enum34 is the new Python stdlib enum module available in Python 3.4
@@ -2158,7 +2158,7 @@ cutting and pasting that code over and over.")
(base32
"1s6cp2lv4m0f00hjckjz8p6m7d3n3v16jvg353llf5ia1iqsnsib"))))
(build-system python-build-system)
- (home-page "https://pypi.python.org/pypi/Unidecode")
+ (home-page "https://pypi.org/project/Unidecode/")
(synopsis "ASCII transliterations of Unicode text")
(description
"Unidecode provides ASCII transliterations of Unicode text. Unidecode is
@@ -3827,7 +3827,7 @@ that client code uses to construct the grammar directly in Python code.")
`(("python-sphinx" ,python-sphinx)))
(native-inputs
`(("python-nose" ,python-nose)))
- (home-page "https://pypi.python.org/pypi/numpydoc")
+ (home-page "https://pypi.org/project/numpydoc/")
(synopsis
"Numpy's Sphinx extensions")
(description
@@ -4777,7 +4777,7 @@ PNG, PostScript, PDF, and SVG file output.")
(sha256
(base32 "0308djallnh00v112y5b7nadl657ysmkp6vc8xn51d6yzc9zm7n3"))))
(build-system python-build-system)
- (home-page "https://pypi.python.org/pypi/decorator/")
+ (home-page "https://pypi.org/project/decorator/")
(synopsis "Python module to simplify usage of decorators")
(description
"The aim of the decorator module is to simplify the usage of decorators
@@ -4806,7 +4806,7 @@ etc. The core of this module is a decorator factory.")
(arguments '(#:tests? #f))
(native-inputs
`(("python-nose" ,python-nose)))
- (home-page "https://pypi.python.org/pypi/drmaa")
+ (home-page "https://pypi.org/project/drmaa/")
(synopsis "Python bindings for the DRMAA library")
(description
"A Python package for Distributed Resource Management (DRM) job
@@ -5021,7 +5021,7 @@ them as the version argument or in a SCM managed file.")
(propagated-inputs
`(("python-scandir" ,python-scandir)
("python-six" ,python-six)))
- (home-page "https://pypi.python.org/pypi/pathlib2/")
+ (home-page "https://pypi.org/project/pathlib2/")
(synopsis "Object-oriented file system paths")
(description "The goal of pathlib2 is to provide a backport of the
standard @code{pathlib} module which tracks the standard library module, so
@@ -6928,7 +6928,7 @@ from an XML-based format.")
(description "This package provides a Python library to parse, manipulate
or create documents in LilyPond format. A command line program ly is also
provided that can be used to do various manipulations with LilyPond files.")
- (home-page "https://pypi.python.org/pypi/python-ly")
+ (home-page "https://pypi.org/project/python-ly/")
(license license:gpl2+)))
(define-public python-appdirs
@@ -7033,7 +7033,7 @@ should be stored on various operating systems.")
(description "MessagePack is a fast, compact binary serialization format,
suitable for similar data to JSON. This package provides CPython bindings for
reading and writing MessagePack data.")
- (home-page "https://pypi.python.org/pypi/msgpack/")
+ (home-page "https://pypi.org/project/msgpack/")
(license license:asl2.0)))
;; This msgpack library's name changed from "python-msgpack" to "msgpack" with
@@ -7526,7 +7526,7 @@ a hash value.")
(arguments
;; There are no tests.
`(#:tests? #f))
- (home-page "https://pypi.python.org/pypi/termcolor")
+ (home-page "https://pypi.org/project/termcolor/")
(synopsis "ANSII Color formatting for terminal output")
(description
"This package provides ANSII Color formatting for output in terminals.")
@@ -8780,7 +8780,7 @@ for the module to work under Python 3.3.")
(synopsis "Colored terminal text rendering for Python")
(description "Colorama is a Python library for rendering colored terminal
text.")
- (home-page "https://pypi.python.org/pypi/colorama")
+ (home-page "https://pypi.org/project/colorama/")
(license license:bsd-3)))
(define-public python2-colorama
@@ -8828,7 +8828,7 @@ library as well as on the command line.")
(synopsis "Plugin and hook calling mechanism for Python")
(description "Pluggy is an extraction of the plugin manager as used by
Pytest but stripped of Pytest specific details.")
- (home-page "https://pypi.python.org/pypi/pluggy")
+ (home-page "https://pypi.org/project/pluggy/")
(license license:expat)))
(define-public python2-pluggy
@@ -9533,7 +9533,7 @@ anymore.")
(propagated-inputs
`(("python2-scandir" ,python2-scandir)
("python2-six" ,python2-six)))
- (home-page "https://pypi.python.org/pypi/pathlib2/")
+ (home-page "https://pypi.org/project/pathlib2/")
(synopsis "Object-oriented file system paths - backport of standard
pathlib module")
(description "The goal of pathlib2 is to provide a backport of standard
@@ -13484,7 +13484,7 @@ which adds support for zone identifiers to IPv6 addresses.")
(base32
"192pclzs2y0yaywqkrlvd0x73740q310kvqvm6jldhi619mq59wi"))))
(build-system python-build-system)
- (home-page "https://pypi.python.org/pypi/rfc3987")
+ (home-page "https://pypi.org/project/rfc3987/")
(synopsis "Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)")
(description "@code{rfc3987} provides routines for parsing and
validation of URIs (see RFC 3986) and IRIs (see RFC 3987).")