summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-03-03 10:35:58 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-03-03 10:35:58 +0100
commitcfe1000bc6959768c6cd6768be1612225d688447 (patch)
tree36a79c4868d42c6124b619a8cba68f2062d36273
parentadb1e3b6cfdd342d1ca95a7901a94543b2585f81 (diff)
downloadpatches-cfe1000bc6959768c6cd6768be1612225d688447.tar
patches-cfe1000bc6959768c6cd6768be1612225d688447.tar.gz
gnu: Add emacs-csv.
* gnu/packages/emacs-xyz.scm (emacs-csv): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index eb1e68deae..60cca75ca1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21692,3 +21692,25 @@ EXIF, XMP and IPTC.")
generate random passwords and insert them into the current buffer. It also
supports generation of phonetic and numeric passwords.")
(license license:artistic2.0)))
+
+(define-public emacs-csv
+ (package
+ (name "emacs-csv")
+ (version "2.1")
+ (home-page "https://gitlab.com/u11/csv.el")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "V" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vmazjrfcsa9aa9aw8bq5sazdhqvhxyj837dyw5lmh8gk7z0xdaa"))))
+ (build-system emacs-build-system)
+ (synopsis "Elisp functions for reading and parsing CSV files")
+ (description "@code{csv.el} provides functions for reading and parsing CSV (Comma
+Separated Value) files. It follows the format as defined in RFC 4180 \"Common
+Format and MIME Type for CSV Files\" (@url{http://tools.ietf.org/html/rfc4180}).")
+ (license license:gpl3+)))