summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-04-06 22:27:23 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-07-23 10:29:34 +1000
commitc842d425933d0b7d6c5e88bb5fd52c3008b8951d (patch)
tree8bb8f00e66d7d8e7c5e425c143d4803aecbda274
parentc62d1a6e6ca693a97eefb3289bea39ddb9779988 (diff)
downloadpatches-c842d425933d0b7d6c5e88bb5fd52c3008b8951d.tar
patches-c842d425933d0b7d6c5e88bb5fd52c3008b8951d.tar.gz
gnu: samtools: Use "modify-phases" syntax.
* gnu/packages/bioinformatics.scm (samtools)[arguments]: Use "modify-phases" syntax.
-rw-r--r--gnu/packages/bioinformatics.scm41
1 files changed, 19 insertions, 22 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 16339f9d6e..7669b4c3f0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4533,29 +4533,26 @@ to the user's query of interest.")
#:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out")))
#:configure-flags (list "--with-ncurses")
#:phases
- (alist-cons-after
- 'unpack 'patch-tests
- (lambda _
- (substitute* "test/test.pl"
- ;; The test script calls out to /bin/bash
- (("/bin/bash") (which "bash")))
- #t)
- (alist-cons-after
- 'install 'install-library
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((lib (string-append (assoc-ref outputs "out") "/lib")))
- (install-file "libbam.a" lib)
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ (substitute* "test/test.pl"
+ ;; The test script calls out to /bin/bash
+ (("/bin/bash") (which "bash")))
#t))
- (alist-cons-after
- 'install 'install-headers
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((include (string-append (assoc-ref outputs "out")
- "/include/samtools/")))
- (for-each (lambda (file)
- (install-file file include))
- (scandir "." (lambda (name) (string-match "\\.h$" name))))
- #t))
- %standard-phases)))))
+ (add-after 'install 'install-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((lib (string-append (assoc-ref outputs "out") "/lib")))
+ (install-file "libbam.a" lib)
+ #t)))
+ (add-after 'install 'install-headers
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((include (string-append (assoc-ref outputs "out")
+ "/include/samtools/")))
+ (for-each (lambda (file)
+ (install-file file include))
+ (scandir "." (lambda (name) (string-match "\\.h$" name))))
+ #t))))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("ncurses" ,ncurses)
("perl" ,perl)