summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-04 11:43:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-04 11:43:38 +0200
commitb274d2a6cb6fddedbc75e09fd55b76cec371d4ff (patch)
treef065ca1b346adbc194e35688575c500c0b00a1aa
parent0b350f73fe649575cfbc2215cc7bab8859184bc9 (diff)
downloadpatches-b274d2a6cb6fddedbc75e09fd55b76cec371d4ff.tar
patches-b274d2a6cb6fddedbc75e09fd55b76cec371d4ff.tar.gz
gnu: vim-fugitive: Use copy-build-system.
* gnu/packages/vim.scm (vim-fugitive)[build-system]: Switch to copy-build-system. [arguments]: Adjust accordingly.
-rw-r--r--gnu/packages/vim.scm28
1 files changed, 7 insertions, 21 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index aa082d7652..4920834898 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -469,28 +469,14 @@ trouble using them, because you do not have to remember each snippet name.")
(sha256
(base32
"1jbn5jxadccmcz01j94d0i1bp74cixr0fpxxf1h0aqdf1ljk3d7n"))))
- (build-system gnu-build-system)
+ (build-system copy-build-system)
(arguments
- '(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (vimfiles (string-append out "/share/vim/vimfiles"))
- (autoload (string-append vimfiles "/autoload"))
- (doc (string-append vimfiles "/doc"))
- (ftdetect (string-append vimfiles "/ftdetect"))
- (plugin (string-append vimfiles "/plugin"))
- (syntax (string-append vimfiles "/syntax")))
- (copy-recursively "autoload" autoload)
- (copy-recursively "doc" doc)
- (copy-recursively "ftdetect" ftdetect)
- (copy-recursively "plugin" plugin)
- (copy-recursively "syntax" syntax)
- #t))))))
+ '(#:install-plan
+ '(("autoload" "share/vim/vimfiles/")
+ ("doc" "share/vim/vimfiles/")
+ ("ftdetect" "share/vim/vimfiles/")
+ ("plugin" "share/vim/vimfiles/")
+ ("syntax" "share/vim/vimfiles/"))))
(home-page "https://github.com/tpope/vim-fugitive")
(synopsis "Vim plugin to work with Git")
(description "Vim-fugitive is a wrapper for Vim that complements the