summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-04 11:39:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-04 11:39:05 +0200
commit84ec7b70090c7bf886cd9d023396d6d2e6e663fb (patch)
treeec2b51f44ec301d1eaf6aa9b4eb1cb7231069a8b
parent0db06e7da943189550c77209f7ebc376df9b0daa (diff)
downloadpatches-84ec7b70090c7bf886cd9d023396d6d2e6e663fb.tar
patches-84ec7b70090c7bf886cd9d023396d6d2e6e663fb.tar.gz
gnu: vim-luna: Use copy-build-system.
* gnu/packages/vim.scm (vim-luna)[build-system]: Switch to copy-build-system. [arguments]: Adjust accordingly.
-rw-r--r--gnu/packages/vim.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index f6c6d036f5..ca39effd14 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -417,20 +417,10 @@ trouble using them, because you do not have to remember each snippet name.")
(sha256
(base32
"0ka3qbhsh8lix1vyj4678j7dnchkd8khhirrnn3aylxxf8fpqyg8"))))
- (build-system gnu-build-system)
+ (build-system copy-build-system)
(arguments
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (vimfiles (string-append out "/share/vim/vimfiles"))
- (colors (string-append vimfiles "/colors")))
- (copy-recursively "colors" colors)
- #t))))))
+ '(#:install-plan
+ '(("colors" "share/vim/vimfiles/"))))
(synopsis "Dark color theme for Vim")
(description
"@code{vim-luna} is a dark color theme for Vim.")