summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-02 23:02:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-02 23:05:49 +0100
commit7316f137dc1679baaf3dcaa180ce15966a2e3bd7 (patch)
tree2c8538bb3771ff40d6700ef083ec1c2857b51f53
parent1639e0b7b60389cf74548544a5e28f9a0b6757c7 (diff)
downloadpatches-7316f137dc1679baaf3dcaa180ce15966a2e3bd7.tar
patches-7316f137dc1679baaf3dcaa180ce15966a2e3bd7.tar.gz
gnu: Add r-kendall.
* gnu/packages/cran.scm (r-kendall): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ca34ee8088..8b0dec9f24 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20555,3 +20555,27 @@ need to derive the partial derivatives.")
for Bayesian estimation. Users specify models via the customary R syntax with
a formula and @code{data.frame} plus some additional arguments for priors.")
(license license:gpl3+)))
+
+(define-public r-kendall
+ (package
+ (name "r-kendall")
+ (version "2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Kendall" version))
+ (sha256
+ (base32
+ "0z2yr3x2nvdm81w2imb61hxwcbmg14kfb2bxgh3wmkmv3wfjwkwn"))))
+ (properties `((upstream-name . "Kendall")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-boot" ,r-boot)))
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (home-page "https://cran.r-project.org/web/packages/Kendall/")
+ (synopsis "Kendall rank correlation and Mann-Kendall trend test")
+ (description
+ "This package computes the Kendall rank correlation and Mann-Kendall
+trend test.")
+ (license license:gpl2+)))