summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasaya Tojo <masaya@tojo.tokyo>2020-03-05 21:37:06 +0900
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-03-05 19:22:42 +0100
commit5d0f33c2ab9aa0cdc51a35525e895a603eac78ea (patch)
tree5d6bc4737bf8ba7143bb40a671356f2d71b87440
parent67c525035f803fe9b17629c28a4fcfdbbefa63c3 (diff)
downloadpatches-5d0f33c2ab9aa0cdc51a35525e895a603eac78ea.tar
patches-5d0f33c2ab9aa0cdc51a35525e895a603eac78ea.tar.gz
* gnu/packages/emacs-xyz.scm (emacs-ddskk): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 19c4ed7571..6bdfd7a640 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -60,6 +60,7 @@
;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
+;;; Copyright © 2020 Masaya Tojo <masaya@tojo.tokyo>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21732,3 +21733,49 @@ supports generation of phonetic and numeric passwords.")
Separated Value) files. It follows the format as defined in RFC 4180 \"Common
Format and MIME Type for CSV Files\" (@url{http://tools.ietf.org/html/rfc4180}).")
(license license:gpl3+)))
+
+(define-public emacs-ddskk
+ ;; XXX: Upstream adds code names to their release tags, so version and code
+ ;; name below need to be updated together.
+ (let ((version "16.3")
+ (code-name "Kutomatsunai"))
+ (package
+ (name "emacs-ddskk")
+ (version version)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/skk-dev/ddskk")
+ (commit (string-append "ddskk-" version "_" code-name))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ln4x8f35z5y3kf9m718g223bn3lzcmw40jfjg2j5yi24ydf1wm9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (guix build emacs-utils))
+ #:imported-modules (,@%gnu-build-system-modules
+ (guix build emacs-utils))
+ #:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (make-file-writable "SKK-MK")
+ (emacs-substitute-variables "SKK-MK"
+ ("PREFIX" (assoc-ref outputs "out"))
+ ("LISPDIR" '(expand-file-name "/share/emacs/site-lisp" PREFIX))
+ ("SKK_PREFIX" "")
+ ("SKK_INFODIR" '(expand-file-name "info" PREFIX)))
+ (for-each make-file-writable (find-files "./doc"))
+ #t)))))
+ (native-inputs
+ `(("emacs-minimal" ,emacs-minimal)))
+ (home-page "https://github.com/skk-dev/ddskk")
+ (synopsis "Simple Kana to Kanji conversion program")
+ (description
+ "Daredevil SKK is a version of @acronym{SKK, Simple Kana to Kanji
+conversion program}, a Japanese input method on Emacs.")
+ (license license:gpl2+))))