summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-03 11:32:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-03 11:33:58 +0100
commit4d5d07f75cc4ff1b1eb27837671d5c2553e8a3d8 (patch)
tree1c7167f1c52e60a8213e670c3b5b48ca5cf26cc0
parent9309fe355e62bb938eaa48ae23d4ffcc566da67d (diff)
downloadpatches-4d5d07f75cc4ff1b1eb27837671d5c2553e8a3d8.tar
patches-4d5d07f75cc4ff1b1eb27837671d5c2553e8a3d8.tar.gz
gnu: gess: Use WRAP-SCRIPT.
* gnu/packages/bioinformatics.scm (gess)[arguments]: Use WRAP-SCRIPT. [inputs]: Add guile-3.0 for wrapper.
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b1913dcaa3..0c12e7c874 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11089,7 +11089,7 @@ import matplotlib
matplotlib.use('Agg')
" line)))
;; Make sure GESS has all modules in its path
- (wrap-program (string-append target "GESS.py")
+ (wrap-script (string-append target "GESS.py")
`("PYTHONPATH" ":" = (,target ,(getenv "PYTHONPATH"))))
(mkdir-p bin)
(symlink (string-append target "GESS.py")
@@ -11101,7 +11101,8 @@ matplotlib.use('Agg')
("python2-scipy" ,python2-scipy)
("python2-numpy" ,python2-numpy)
("python2-networkx" ,python2-networkx)
- ("python2-biopython" ,python2-biopython)))
+ ("python2-biopython" ,python2-biopython)
+ ("guile" ,guile-3.0))) ; for the script wrapper
(home-page "https://compbio.uthscsa.edu/GESS_Web/")
(synopsis "Detect exon-skipping events from raw RNA-seq data")
(description