summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <leungbk@mailfence.com>2019-09-23 19:58:50 +0200
committerBrian Leung <leungbk@mailfence.com>2019-09-23 20:00:29 +0200
commit4343eebfc9f7d44ec9a665f3374d1397301b542e (patch)
tree870bfc962c3c415435d715ded158cd615ce37190
parent676487049849ca6cebe03f19f171ca912c5e8741 (diff)
downloadpatches-4343eebfc9f7d44ec9a665f3374d1397301b542e.tar
patches-4343eebfc9f7d44ec9a665f3374d1397301b542e.tar.gz
gnu: emacs-ace-window: Update to 0.9.0-1.a534492.
* gnu/packages/emacs-xyz.scm (emacs-ace-window): Update to 0.9.0-1.a534492.
-rw-r--r--gnu/packages/emacs-xyz.scm44
1 files changed, 24 insertions, 20 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 86e2edebbb..86653293f9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5202,29 +5202,33 @@ windows.")
(license license:gpl3+)))
(define-public emacs-ace-window
- (package
- (name "emacs-ace-window")
- (version "0.9.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/abo-abo/ace-window.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "07mcdzjmgrqdvjs94f2n5bkrf5vrq2fwzz256wbm3wzqxqkfy1q6"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-avy" ,emacs-avy)))
- (home-page "https://github.com/abo-abo/ace-window")
- (synopsis "Quickly switch windows in Emacs")
- (description
- "@code{ace-window} is meant to replace @code{other-window}.
+ ;; last release version is from 2015
+ (let ((commit "a5344925e399e1f015721cda6cf5db03c90ab87a")
+ (revision "1"))
+ (package
+ (name "emacs-ace-window")
+ (version (git-version "0.9.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/abo-abo/ace-window.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18jm8gfgnf6ja9aarws5650lw2zfi3wdwc5j8r5ijn5fcqhfy7rc"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-avy" ,emacs-avy)))
+ (home-page "https://github.com/abo-abo/ace-window")
+ (synopsis "Quickly switch windows in Emacs")
+ (description
+ "@code{ace-window} is meant to replace @code{other-window}.
In fact, when there are only two windows present, @code{other-window} is
called. If there are more, each window will have its first character
highlighted. Pressing that character will switch to that window.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-iedit
;; Last release version was in 2016.