summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-07-18 11:37:05 +0300
committerRicardo Wurmus <rekado@elephly.net>2017-07-22 12:26:29 +0200
commit3fee00395031a7144b108c2839fcbb570d5df8bd (patch)
tree40f969836722fef9778e1c16935c5dc5285350a7
parentde469015c4422b21d4619b8ff8a0fc8d917c7794 (diff)
downloadpatches-3fee00395031a7144b108c2839fcbb570d5df8bd.tar
patches-3fee00395031a7144b108c2839fcbb570d5df8bd.tar.gz
gnu: Update python-pytz to 2017.2.
* gnu/packages/python.scm (python-pytz, python2-pytz): Update to 2017.2. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d3832f30fb..da139c2473 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -43,6 +43,7 @@
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -653,27 +654,28 @@ on localhost.")
(define-public python-pytz
(package
(name "python-pytz")
- (version "2016.10")
+ (version "2017.2")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "pytz" version ".tar.bz2"))
+ (uri (pypi-uri "pytz" version ".zip"))
(sha256
(base32
- "0az099cyp6p5xbsvfcdacj4hvxncbwm2ayn3h55mcp07zb2b45kh"))))
+ "12cmd3j46d2gcw08bspvp6s9icfcvx88zjz52n1bli9dyvl5dh7m"))))
(build-system python-build-system)
- (arguments `(#:tests? #f)) ; no test target
+ (native-inputs
+ `(("unzip" ,unzip)))
(home-page "http://pythonhosted.org/pytz")
(synopsis "Python timezone library")
- (description
- "This library allows accurate and cross platform timezone calculations
-using Python 2.4 or higher and provides access to the Olson timezone database.")
+ (description "This library brings the Olson tz database into Python. It
+allows accurate and cross platform timezone calculations using Python 2.4 or
+higher. It also solves the issue of ambiguous times at the end of daylight
+saving time. Almost all of the Olson timezones are supported.")
(license license:expat)))
(define-public python2-pytz
(package-with-python2 python-pytz))
-
(define-public python-babel
(package
(name "python-babel")