summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-02-09 20:48:34 +0300
committerMarius Bakke <mbakke@fastmail.com>2017-02-09 23:41:23 +0100
commit2f4623dbd85bab738056e5898ea9a2aadfc49733 (patch)
tree28f8a8a4551ab533b15bfa956730978a9ee03cad
parent1f42d824c1fb3790da93ef2596776e23dc57c0c9 (diff)
downloadpatches-2f4623dbd85bab738056e5898ea9a2aadfc49733.tar
patches-2f4623dbd85bab738056e5898ea9a2aadfc49733.tar.gz
gnu: Add python-ddt.
* gnu/packages/python.scm (python-ddt, python2-ddt): New variables. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index da6deb51c2..7ee9376f21 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12580,3 +12580,31 @@ faster ones are not available.")
"Python module dedicated to rendering RST (reStructuredText) documents
to ansi-escaped strings suitable for display in a terminal.")
(license license:expat)))
+
+(define-public python-ddt
+ (package
+ (name "python-ddt")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ddt" version))
+ (sha256
+ (base32
+ "1c00ikkxr7lha97c81k938bzhgd4pbwamkjn0h4nkhr3xk00zp6n"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-pyyaml" ,python-pyyaml)))
+ (home-page "https://github.com/txels/ddt")
+ (synopsis "Data-Driven Tests")
+ (description
+ "DDT (Data-Driven Tests) allows you to multiply one test case by running
+it with different test data, and make it appear as multiple test cases.")
+ (license license:expat)))
+
+(define-public python2-ddt
+ (package-with-python2 python-ddt))