summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-02 23:08:13 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-02 23:39:44 +0100
commit1f8838d1f6295e10851b2915dc3b0a97b3bbc236 (patch)
tree91397dc0c32ff471b0b24a4d7e8cbb3e515629da
parent1e07875b577a197730b363bdbf0d9d4da8011571 (diff)
downloadpatches-1f8838d1f6295e10851b2915dc3b0a97b3bbc236.tar
patches-1f8838d1f6295e10851b2915dc3b0a97b3bbc236.tar.gz
gnu: libgc: Fix replacement inheritance.
* gnu/packages/bdw-gc.scm (libgc-8.0): Do not use PACKAGE/INHERIT, because it does not make sense to inherit any replacements of LIBGC. (libgc/back-pointers): Use PACKAGE/INHERIT.
-rw-r--r--gnu/packages/bdw-gc.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index f0cff707f3..73b0c073d9 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -92,8 +92,8 @@ C or C++ programs, though that is not its primary goal.")
(license (x11-style (string-append home-page "license.txt")))))
(define-public libgc-8.0
- (package/inherit
- libgc
+ (package
+ (inherit libgc)
(version "8.0.4")
(source (origin
(method url-fetch)
@@ -104,8 +104,8 @@ C or C++ programs, though that is not its primary goal.")
"1798rp3mcfkgs38ynkbg2p47bq59pisrc6mn0l20pb5iczf0ssj3"))))))
(define-public libgc/back-pointers
- (package
- (inherit libgc)
+ (package/inherit
+ libgc
(name "libgc-back-pointers")
(arguments
`(#:make-flags