summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-04 12:04:52 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-04 12:04:52 +0200
commit12fe38a1d651c9ea48c0de27ef103c676f699396 (patch)
treea0200f87650257cef468983f8bd127c3628bc738
parent94d53fbb07074132c0052e998bb287a7f464b9be (diff)
downloadpatches-12fe38a1d651c9ea48c0de27ef103c676f699396.tar
patches-12fe38a1d651c9ea48c0de27ef103c676f699396.tar.gz
gnu: vim-guix-vim: Use copy-build-system.
* gnu/packages/vim.scm (vim-guix-vim)[build-system]: Switch to copy-build-system. [arguments]: Adjust accordingly.
-rw-r--r--gnu/packages/vim.scm23
1 files changed, 8 insertions, 15 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index bed9783281..b468347380 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -834,22 +834,15 @@ through its msgpack-rpc API.")
(sha256
(base32
"1f8h8m96fqh3f9hy87spgh9kdqzyxl11n9s3rywvyq5xhn489bnk"))))
- (build-system gnu-build-system)
+ (build-system copy-build-system)
(arguments
- '(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (vimfiles (string-append out "/share/vim/vimfiles")))
- (for-each
- (lambda (dir)
- (copy-recursively dir (string-append vimfiles "/" dir)))
- '("compiler" "doc" "indent" "ftdetect" "ftplugin" "syntax"))
- #t))))))
+ '(#:install-plan
+ '(("compiler" "share/vim/vimfiles/")
+ ("doc" "share/vim/vimfiles/")
+ ("indent" "share/vim/vimfiles/")
+ ("ftdetect" "share/vim/vimfiles/")
+ ("ftplugin" "share/vim/vimfiles/")
+ ("syntax" "share/vim/vimfiles/"))))
(home-page "https://gitlab.com/Efraim/guix.vim")
(synopsis "Guix integration in Vim")
(description "This package provides support for GNU Guix in Vim.")