summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-02 23:02:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-02 23:05:49 +0100
commit11ab52888d416d9fcf33349b1f376f7e47f4cdff (patch)
tree72aebb47533e70d1872d8d39b2ca5bb63185506a
parent505d6716d0df1dc5e8ef3438f0d7ec68c695d874 (diff)
downloadpatches-11ab52888d416d9fcf33349b1f376f7e47f4cdff.tar
patches-11ab52888d416d9fcf33349b1f376f7e47f4cdff.tar.gz
gnu: Add r-zvcv.
* gnu/packages/cran.scm (r-zvcv): New variable.
-rw-r--r--gnu/packages/cran.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7bc85106b3..87d0eb81e0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20603,3 +20603,37 @@ method (Sen, 1968) plus implementation of Xuebin Zhang's (Zhang, 1999) and
Yue-Pilon's (Yue, 2002) pre-whitening approaches to determining trends in
climate data.")
(license license:lgpl2.1)))
+
+(define-public r-zvcv
+ (package
+ (name "r-zvcv")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ZVCV" version))
+ (sha256
+ (base32
+ "1npw836q2skx54843lgxvb0rfwafckjc8k8dljykm60ad3z7zak8"))))
+ (properties `((upstream-name . "ZVCV")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-abind" ,r-abind)
+ ("r-glmnet" ,r-glmnet)
+ ("r-mvtnorm" ,r-mvtnorm)
+ ("r-partitions" ,r-partitions)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)))
+ (home-page "https://cran.r-project.org/web/packages/ZVCV/")
+ (synopsis "Zero-Variance Control Variates")
+ (description
+ "@dfn{Zero-variance control variates} (ZV-CV) is a post-processing method
+to reduce the variance of Monte Carlo estimators of expectations using the
+derivatives of the log target. Once the derivatives are available, the only
+additional computational effort is in solving a linear regression problem.
+This method has been extended to higher dimensions using regularisation. This
+package can be used to easily perform ZV-CV or regularised ZV-CV when a set of
+samples, derivatives and function evaluations are available. Additional
+functions for applying ZV-CV to two estimators for the normalising constant of
+the posterior distribution in Bayesian statistics are also supplied.")
+ (license license:gpl2+)))