summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-04 11:36:24 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-04 11:36:24 +0200
commit0db06e7da943189550c77209f7ebc376df9b0daa (patch)
tree60e6a3da736112456ba5d1a9c4f53e7d48438f20
parentf19e539c3e7f9df06f413eeb9439925dedf03715 (diff)
downloadpatches-0db06e7da943189550c77209f7ebc376df9b0daa.tar
patches-0db06e7da943189550c77209f7ebc376df9b0daa.tar.gz
gnu: vim-scheme: Use copy-build-system.
* gnu/packages/vim.scm (vim-scheme)[build-system]: Switch to copy-build-system. [arguments]: Adjust accordingly.
-rw-r--r--gnu/packages/vim.scm22
1 files changed, 5 insertions, 17 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 7588d9cbbd..f6c6d036f5 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -389,24 +389,12 @@ trouble using them, because you do not have to remember each snippet name.")
(sha256
(base32
"1ynjr1109dxgj0lz261gmzz3wf5ap1m6j6hnvl3lcyv66a4y8pjv"))))
- (build-system gnu-build-system)
+ (build-system copy-build-system)
(arguments
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (vimfiles (string-append out "/share/vim/vimfiles"))
- (after (string-append vimfiles "/after"))
- (syntax (string-append vimfiles "/syntax"))
- (ftplugin (string-append vimfiles "/ftplugin")))
- (copy-recursively "after" after)
- (copy-recursively "ftplugin" ftplugin)
- (copy-recursively "syntax" syntax)
- #t))))))
+ '(#:install-plan
+ '(("after" "share/vim/vimfiles/")
+ ("ftplugin" "share/vim/vimfiles/")
+ ("syntax" "share/vim/vimfiles/"))))
(synopsis "Scheme syntax for Vim")
(description
"@code{vim-scheme} provides Scheme support for Vim (R7RS and CHICKEN).")