summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-02-03 12:28:18 +0100
committerRoel Janssen <roel@gnu.org>2020-03-04 09:05:39 +0100
commit5e860b606265ba5bafae695d07410354680b080c (patch)
tree0c7df6063cb9c09cc08b63449543f814eb4ea840
parent4b759d3c548270eba348521669bae15c9e5b72bc (diff)
downloadpatches-5e860b606265ba5bafae695d07410354680b080c.tar
patches-5e860b606265ba5bafae695d07410354680b080c.tar.gz
gnu: Add perl-pdf-api2.
* gnu/packages/perl.scm (perl-pdf-api2): New variable.
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index f513a78f76..1797766db5 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7247,6 +7247,30 @@ file names.")
with file paths.")
(license asl2.0)))
+(define-public perl-pdf-api2
+ (package
+ (name "perl-pdf-api2")
+ (version "2.036")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/S/SS/SSIMMS/PDF-API2-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0x0pa75wpb87pcshl92y5nh8pzikjp46ljlr2pqvdgpqzvll8107"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-exception" ,perl-test-exception)
+ ("perl-test-memory-cycle" ,perl-test-memory-cycle)))
+ (propagated-inputs
+ `(("perl-font-ttf" ,perl-font-ttf)))
+ (home-page "https://metacpan.org/release/PDF-API2")
+ (synopsis "Facilitates the creation and modification of PDF files")
+ (description "This Perl module facilitates the creation and modification
+of PDF files.")
+ (license lgpl2.1)))
+
(define-public perl-perlio-utf8_strict
(package
(name "perl-perlio-utf8-strict")