summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-04 10:44:28 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-04 10:52:52 +0200
commita18ed1711f4762649fbaa5e8d69e536b4ba22fae (patch)
tree2000b037da3ffb33f5886294dd44f7e4038dd918
parent790b66e34fd81cdda246361303072065e6339c97 (diff)
downloadpatches-a18ed1711f4762649fbaa5e8d69e536b4ba22fae.tar
patches-a18ed1711f4762649fbaa5e8d69e536b4ba22fae.tar.gz
gnu: ucd: Use copy-build-system.
* gnu/packages/unicode.scm (ucd)[build-system]: Switch to copy-build-system. [arguments]: Adjust accordingly.
-rw-r--r--gnu/packages/unicode.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/unicode.scm b/gnu/packages/unicode.scm
index 3b34096fe5..44ef279144 100644
--- a/gnu/packages/unicode.scm
+++ b/gnu/packages/unicode.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix utils)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system trivial))
(define-public ucd
@@ -35,15 +37,10 @@
(sha256
(base32
"1ighy39cjkmqnv1797wrxjz76mv1fdw7zp5j04q55bkwxsdkvrmh"))))
- (build-system trivial-build-system)
+ (build-system copy-build-system)
(arguments
- `(#:modules ((guix build utils))
- #:builder
- (let ((out (string-append %output "/share/ucd")))
- (use-modules (guix build utils))
- (mkdir-p out)
- (copy-recursively (assoc-ref %build-inputs "source") out)
- #t)))
+ '(#:install-plan
+ '(("." "share/ucd/"))))
(home-page "https://www.unicode.org")
(synopsis "Unicode Character Database")
(description