summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-02-27 09:27:14 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-02-27 09:34:46 -0500
commitfaa0fa3978bad240f245c79aa487e0594ae9fc9a (patch)
tree5df8a058bce9321e5be9e11285393d9fe5d7bca7
parente64c5a8fe4e99eb4af24ca37574b5d4ab5a389d6 (diff)
downloadpatches-faa0fa3978bad240f245c79aa487e0594ae9fc9a.tar
patches-faa0fa3978bad240f245c79aa487e0594ae9fc9a.tar.gz
gnu: earlyoom: Update to latest commit to resolve a test failure.
* gnu/packages/linux.scm (earlyoom): Update to commit 7bd4b2c9a285d2b9a4ef6e7a080e83ab95fcdeea.
-rw-r--r--gnu/packages/linux.scm85
1 files changed, 45 insertions, 40 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0b656629df..50fa7b31d0 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2737,49 +2737,54 @@ kmod. The aim is to be compatible with tools, configurations and indices
from the module-init-tools project.")
(license license:gpl2+))) ; library under lgpl2.1+
+;;; Use a recent commit, because the latest 1.3 tag suffers from test failures
+;;; (see:
+;;; https://github.com/rfjakob/earlyoom/issues/156#issuecomment-591997405).
(define-public earlyoom
- (package
- (name "earlyoom")
- (version "1.3")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rfjakob/earlyoom.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0fwbx0y80nqgkxrc9kf9j3iwa0wbps2jmqir3pgqbc2cj0wjh0lr"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'check 'set-home
- (lambda _
- (setenv "HOME" (getcwd))
- #t))
- (add-after 'build 'install-contribs
- ;; Install what seems useful from the contrib directory.
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (contrib (string-append
- out "/share/earlyoom/contrib")))
- (install-file "contrib/notify_all_users.py" contrib)
- #t))))
- #:make-flags (let* ((prefix (assoc-ref %outputs "out")))
- (list "CC=gcc"
- (string-append "VERSION=v" ,version)
- (string-append "PREFIX=" prefix)
- (string-append "SYSCONFDIR=" prefix "/etc")))
- #:test-target "test"))
- (native-inputs `(("go" ,go) ;for the test suite
- ("pandoc" ,ghc-pandoc))) ;to generate the manpage
- (home-page "https://github.com/rfjakob/earlyoom")
- (synopsis "Simple out of memory (OOM) daemon for the Linux kernel")
- (description "Early OOM is a minimalist out of memory (OOM) daemon that
+ (let ((commit "7bd4b2c9a285d2b9a4ef6e7a080e83ab95fcdeea")
+ (revision "1"))
+ (package
+ (name "earlyoom")
+ (version (git-version "1.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rfjakob/earlyoom.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0sxk8gh734q4rbh9r1q8ab840bn4kffdm8j93x55jspnmmy1wd2c"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'check 'set-home
+ (lambda _
+ (setenv "HOME" (getcwd))
+ #t))
+ (add-after 'build 'install-contribs
+ ;; Install what seems useful from the contrib directory.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (contrib (string-append
+ out "/share/earlyoom/contrib")))
+ (install-file "contrib/notify_all_users.py" contrib)
+ #t))))
+ #:make-flags (let* ((prefix (assoc-ref %outputs "out")))
+ (list "CC=gcc"
+ (string-append "VERSION=v" ,version)
+ (string-append "PREFIX=" prefix)
+ (string-append "SYSCONFDIR=" prefix "/etc")))
+ #:test-target "test"))
+ (native-inputs `(("go" ,go) ;for the test suite
+ ("pandoc" ,ghc-pandoc))) ;to generate the manpage
+ (home-page "https://github.com/rfjakob/earlyoom")
+ (synopsis "Simple out of memory (OOM) daemon for the Linux kernel")
+ (description "Early OOM is a minimalist out of memory (OOM) daemon that
runs in user space and provides a more responsive and configurable alternative
to the in-kernel OOM killer.")
- (license license:expat)))
+ (license license:expat))))
(define-public eudev
;; The post-systemd fork, maintained by Gentoo.