summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2020-02-21 17:17:56 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-02-28 09:39:55 +0100
commit3282137d0e4a32cd1c6b049e6ce7c44ab65bfdff (patch)
tree58a29a1301a897a709fd2c1cc77ec267bce23b58
parenta3b1f878dfeddfc8516fba8483e3191a3e4c887e (diff)
downloadpatches-3282137d0e4a32cd1c6b049e6ce7c44ab65bfdff.tar
patches-3282137d0e4a32cd1c6b049e6ce7c44ab65bfdff.tar.gz
gnu: delft-icon-theme: Use the copy-build-system.
* gnu/packages/gnome-xyz.scm (delft-icon-theme): Use the copy-build-system. Signed-off-by: Pierre Neidhardt <mail@ambrevar.xyz>
-rw-r--r--gnu/packages/gnome-xyz.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index bedaacf092..b0bc35c4b1 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -101,19 +101,17 @@ like Gnome, Unity, Budgie, Pantheon, XFCE, Mate and others.")
(base32
"0vw3yw9f9ygzfd2k3zrfih3r0vkzlhk1bmsk8sapvk7np24i1z9s"))
(file-name (git-file-name name version))))
- (build-system trivial-build-system)
+ (build-system copy-build-system)
(arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (copy-recursively (assoc-ref %build-inputs "source") "icons")
- (substitute* "icons/Delft/index.theme"
- (("gnome") "Adwaita"))
- (delete-file "icons/README.md")
- (delete-file "icons/LICENSE")
- (delete-file "icons/logo.jpg")
- (copy-recursively "icons" (string-append %output "/share/icons")))))
+ `(#:install-plan
+ `(("." "share/icons" #:exclude ("README.md" "LICENSE" "logo.jpg")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-index.theme
+ (lambda _
+ (substitute* "Delft/index.theme"
+ (("gnome") "Adwaita"))
+ #t)))))
(home-page "https://www.gnome-look.org/p/1199881/")
(synopsis "Continuation of Faenza icon theme with up to date app icons")
(description "Delft is a fork of the popular icon theme Faenza with up to