summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-02-02 01:42:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-27 20:59:45 +0200
commitede4cbc0ba4276004f83762ff030a22b25f1c72b (patch)
tree10edc2472af20ec7477b848de11921d417d52ece
parentd125c4f428c20d75c72ef21455649ca76f1bfeba (diff)
downloadpatches-ede4cbc0ba4276004f83762ff030a22b25f1c72b.tar
patches-ede4cbc0ba4276004f83762ff030a22b25f1c72b.tar.gz
gnu: Add rust-wasm-bindgen-futures-0.4 and its dependencies.
* gnu/packages/crates-io.scm (rust-wasm-bindgen-futures-0.4): New variable. * gnu/packages/crates-io.scm (rust-wasm-bindgen-test-0.3): New variable. * gnu/packages/crates-io.scm (rust-web-sys-0.3): New variable. Added in one commit because they have cyclic dependencies on each other. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm94
1 files changed, 94 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 37b97b5ca8..968b75a56d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -19302,6 +19302,37 @@ in Rust.")
"Backend code generation of the wasm-bindgen tool.")
(license (list license:expat license:asl2.0))))
+(define-public rust-wasm-bindgen-futures-0.4
+ (package
+ (name "rust-wasm-bindgen-futures")
+ (version "0.4.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "wasm-bindgen-futures" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1n9ma4kinr4w6r2sh4wm04my6p14k1vx3a4vdbn0vd187sgd9gcb"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-cfg-if" ,rust-cfg-if-0.1)
+ ("rust-js-sys" ,rust-js-sys-0.3)
+ ("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
+ ("rust-web-sys" ,rust-web-sys-0.3))
+ #:cargo-development-inputs
+ (("rust-futures-channel-preview" ,rust-futures-channel-preview-0.3)
+ ("rust-wasm-bindgen-test" ,rust-wasm-bindgen-test-0.3))))
+ (home-page "https://rustwasm.github.io/wasm-bindgen/")
+ (synopsis
+ "Bridging the gap between Rust Futures and JavaScript Promises")
+ (description
+ "Bridging the gap between Rust Futures and JavaScript Promises.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-wasm-bindgen-futures-0.3
(package
(name "rust-wasm-bindgen-futures")
@@ -19415,6 +19446,36 @@ attribute that is not in the shared backend crate.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-wasm-bindgen-test-0.3
+ (package
+ (name "rust-wasm-bindgen-test")
+ (version "0.3.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "wasm-bindgen-test" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0bn833hghwbcg9cqz1bx9biq271bc4jcbgn2nqk1fkf4ab1hxzcq"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-console-error-panic-hook" ,rust-console-error-panic-hook-0.1)
+ ("rust-js-sys" ,rust-js-sys-0.3)
+ ("rust-scoped-tls" ,rust-scoped-tls-1.0)
+ ("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
+ ("rust-wasm-bindgen-futures" ,rust-wasm-bindgen-futures-0.4)
+ ("rust-wasm-bindgen-test-macro" ,rust-wasm-bindgen-test-macro-0.3))))
+ (home-page "https://github.com/rustwasm/wasm-bindgen")
+ (synopsis
+ "Internal testing crate for wasm-bindgen")
+ (description
+ "Internal testing crate for wasm-bindgen.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-wasm-bindgen-test-0.2
(package
(name "rust-wasm-bindgen-test")
@@ -19518,6 +19579,39 @@ attribute that is not in the shared backend crate.")
"Support for parsing WebIDL specific to wasm-bindgen.")
(license (list license:expat license:asl2.0))))
+(define-public rust-web-sys-0.3
+ (package
+ (name "rust-web-sys")
+ (version "0.3.35")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "web-sys" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0fzmxcyahy3ghl8lkjkchj9krmnr56shvbqgr7db3hm8dappryda"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-js-sys" ,rust-js-sys-0.3)
+ ("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
+ ("rust-anyhow" ,rust-anyhow-1.0)
+ ("rust-env-logger" ,rust-env-logger-0.7)
+ ("rust-sourcefile" ,rust-sourcefile-0.1)
+ ("rust-wasm-bindgen-webidl" ,rust-wasm-bindgen-webidl-0.2))
+ #:cargo-development-inputs
+ (("rust-wasm-bindgen-futures" ,rust-wasm-bindgen-futures-0.4)
+ ("rust-wasm-bindgen-test" ,rust-wasm-bindgen-test-0.3))))
+ (home-page "https://rustwasm.github.io/wasm-bindgen/web-sys/index.html")
+ (synopsis
+ "Bindings for all Web APIs, a procedurally generated crate from WebIDL")
+ (description
+ "Bindings for all Web APIs, a procedurally generated crate from WebIDL.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-weedle-0.10
(package
(name "rust-weedle")