summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-28 15:53:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-28 16:53:04 +0300
commitc4b7a9abb654c84d815dbd927f0a6c259bd336a0 (patch)
tree537c3115cf166f74389916d22de403bd327a3b91
parent36bd543afc4d248093f1f07c150a5031fcec70f8 (diff)
downloadpatches-c4b7a9abb654c84d815dbd927f0a6c259bd336a0.tar
patches-c4b7a9abb654c84d815dbd927f0a6c259bd336a0.tar.gz
gnu: Add rust-futures-io-preview.
* gnu/packages/crates-io.scm (rust-futures-io-preview): New variable.
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c2af57eb90..03f2a11445 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -478,6 +478,26 @@ featuring zero allocations, composability, and iterator-like interfaces.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-futures-io-preview
+ (package
+ (name "rust-futures-io-preview")
+ (version "0.3.0-alpha.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "futures-io-preview" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0fhvwhdb8ywjjbfng0ra1r8yyc9yzpyxg9sv3spb3f7w0lk40bh8"))))
+ (build-system cargo-build-system)
+ (home-page "https://rust-lang-nursery.github.io/futures-rs/")
+ (synopsis "Async read and write traits for the futures library")
+ (description "This crate provides the @code{AsyncRead} and
+@code{AsyncWrite} traits for the @code{futures-rs} library.")
+ (license (list license:asl2.0
+ license:expat))))
+
(define-public rust-hex
(package
(name "rust-hex")