summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-02-27 14:06:57 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-02-27 14:06:57 +0100
commita69bc7386f22687015bcb326e7f13f353b8fedc4 (patch)
treed1099d7052ede721f7c41e290a153159feab77b0
parente10587c5a597a62178cfa5bcc7242f94728ccd0b (diff)
downloadpatches-a69bc7386f22687015bcb326e7f13f353b8fedc4.tar
patches-a69bc7386f22687015bcb326e7f13f353b8fedc4.tar.gz
gnu: Add lttng-ust.
* gnu/packages/linux.scm (lttng-ust): New variable.
-rw-r--r--gnu/packages/linux.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 78182555c1..0b656629df 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2019 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6382,3 +6383,28 @@ the Linux kernel, C standard library, and libdl (for dynamic linking). While
ELL is designed to be efficient and compact enough for use on embedded Linux
platforms, it is not limited to resource-constrained systems.")
(license license:lgpl2.1+)))
+
+(define-public lttng-ust
+ (package
+ (name "lttng-ust")
+ (version "2.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://lttng.org/files/lttng-ust/"
+ "lttng-ust-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1n646yz7882svf5a4ay3vqiiz3qjn3pgkkij9kk22871wp7q0ck8"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("liburcu" ,liburcu)
+ ("numactl" ,numactl)))
+ (native-inputs
+ `(("python" ,python-3)))
+ (home-page "https://lttng.org/")
+ (synopsis "LTTng userspace tracer libraries")
+ (description "The user space tracing library, liblttng-ust, is the LTTng
+user space tracer. It receives commands from a session daemon, for example to
+enable and disable specific instrumentation points, and writes event records
+to ring buffers shared with a consumer daemon.")
+ (license license:lgpl2.1+)))