summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-02-02 03:43:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-27 20:59:53 +0200
commit7cb8191cce7b3b38fc75efa44c38417ab6853ea3 (patch)
tree84a7ead40a09c8fd2b806a8985d2219573d4a015
parent293334468b693bc0d10c9a3de7b1b68721cfcb95 (diff)
downloadpatches-7cb8191cce7b3b38fc75efa44c38417ab6853ea3.tar
patches-7cb8191cce7b3b38fc75efa44c38417ab6853ea3.tar.gz
gnu: Add rust-native-tls-0.2.
* gnu/packages/crates-io.scm (rust-native-tls-0.2): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 883c64fd90..bcee89b2b2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -9684,6 +9684,52 @@ checking.")
IO of Windows's named pipes.")
(license (list license:expat license:asl2.0))))
+(define-public rust-native-tls-0.2
+ (package
+ (name "rust-native-tls")
+ (version "0.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "native-tls" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ki7cj4wzyd2nach4qdjly69sp7rs0yz3n3z2ii4mm1gqajg2bab"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; tests require network access
+ #:cargo-inputs
+ (("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-openssl" ,rust-openssl-0.10)
+ ("rust-openssl-probe" ,rust-openssl-probe-0.1)
+ ("rust-openssl-sys" ,rust-openssl-sys-0.9)
+ ("rust-schannel" ,rust-schannel-0.1)
+ ("rust-security-framework" ,rust-security-framework-0.3)
+ ("rust-security-framework-sys" ,rust-security-framework-sys-0.3)
+ ("rust-tempfile" ,rust-tempfile-3.1))
+ #:cargo-development-inputs
+ (("rust-hex" ,rust-hex-0.3))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'find-openssl
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((openssl (assoc-ref inputs "openssl")))
+ (setenv "OPENSSL_DIR" openssl))
+ #t)))))
+ (native-inputs
+ `(("openssl" ,openssl)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/sfackler/rust-native-tls")
+ (synopsis
+ "Wrapper over a platform's native TLS implementation")
+ (description
+ "This package provides a wrapper over a platform's native TLS implementation.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-natord-1.0
(package
(name "rust-natord")