summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-02-27 17:37:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-27 17:38:17 +0100
commit6c32e9b4dc7e7cbf6580e7b97d1c526cb15c6099 (patch)
tree56f7956667afc03fca23c6691cd1bb0a5c35afa7
parentd24b3b02133e5e3ccc4236656c60377a369bd7b5 (diff)
downloadpatches-6c32e9b4dc7e7cbf6580e7b97d1c526cb15c6099.tar
patches-6c32e9b4dc7e7cbf6580e7b97d1c526cb15c6099.tar.gz
gnu: bedtools: Update to 2.29.2.
* gnu/packages/bioinformatics.scm (bedtools): Update to 2.29.2. [native-inputs]: Replace python-2 with python-wrapper. [license]: Change to Expat.
-rw-r--r--gnu/packages/bioinformatics.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 51ffa00860..2b13ad4839 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -410,7 +410,7 @@ computational cluster.")
(define-public bedtools
(package
(name "bedtools")
- (version "2.27.1")
+ (version "2.29.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/arq5x/bedtools2/releases/"
@@ -418,7 +418,7 @@ computational cluster.")
"bedtools-" version ".tar.gz"))
(sha256
(base32
- "1ndg5yknrxl4djx8ddzgk12rrbiidfpmkkg5z3f95jzryfxarhn8"))))
+ "0m3hk6548846w83a9s5drsczvy67n2azx41kj71n03klb2gbzwg3"))))
(build-system gnu-build-system)
(arguments
'(#:test-target "test"
@@ -427,7 +427,8 @@ computational cluster.")
#:phases
(modify-phases %standard-phases
(delete 'configure))))
- (native-inputs `(("python" ,python-2)))
+ (native-inputs
+ `(("python" ,python-wrapper)))
(inputs
`(("samtools" ,samtools)
("zlib" ,zlib)))
@@ -440,7 +441,7 @@ genome arithmetic: that is, set theory on the genome. For example, bedtools
allows one to intersect, merge, count, complement, and shuffle genomic
intervals from multiple files in widely-used genomic file formats such as BAM,
BED, GFF/GTF, VCF.")
- (license license:gpl2)))
+ (license license:expat)))
;; Later releases of bedtools produce files with more columns than
;; what Ribotaper expects.