summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-02-02 02:23:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-27 20:59:47 +0200
commit36908ef9f0af65bf32949a427c27410980d70b49 (patch)
tree0a4f4bdb627bc031ebf8f7e9a95d572295b05e8a
parentd5eee77850c313d5bc235740f052cf1f08c166f6 (diff)
downloadpatches-36908ef9f0af65bf32949a427c27410980d70b49.tar
patches-36908ef9f0af65bf32949a427c27410980d70b49.tar.gz
gnu: Add rust-wayland-commons-0.23.
* gnu/packages/crates-io.scm (rust-wayland-commons-0.23): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 220bcbfefd..a86e91cc86 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -19649,6 +19649,31 @@ You should only need this crate if you are working on custom wayland
protocol extensions. Look at the crate wayland-client for usable bindings.")
(license license:expat)))
+(define-public rust-wayland-commons-0.23
+ (package
+ (name "rust-wayland-commons")
+ (version "0.23.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "wayland-commons" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1nyvcs6xxxzqgh0wvc7z0fgi89bf3h9p4qrbf77bnfbwlb8v0rmv"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-nix" ,rust-nix-0.14)
+ ("rust-wayland-sys" ,rust-wayland-sys-0.23))))
+ (home-page "https://github.com/smithay/wayland-rs")
+ (synopsis
+ "Common types and structures used by wayland-client and wayland-server")
+ (description
+ "Common types and structures used by wayland-client and wayland-server.")
+ (license license:expat)))
+
(define-public rust-web-sys-0.3
(package
(name "rust-web-sys")